iMac 24" 3.06GHz has problems with going to sleep

Discussion in 'iMac' started by allan.nyholm, Mar 24, 2009.

  1. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #1
    Hello everyone.

    I have run into an odd problem. My fairly new iMac 24" from last June has trouble going to sleep using the settings in Energy Saver preferences. I have recently reinstalled OS X and nothing was wrong with sleep before the reinstall, as far as I remember. I have the settings set to default right now and the iMac just won't go to sleep.

    I have reset PRAM and unplugging all cables overnight(I heard that it does something wonderful to the computer) But I can't remember if it resets something or what.

    My open apps are the usual suspects like Safari, Adium, iTunes and Mailplane - I do have a lot of background apps running; Logitech Control Center, FinderPop, Growl, iStat menus, Antipop(for getting ridding of speaker pops whilst the system sound is idle) - I can't quite pinpoint the thing that stops my iMac from sleeping on its own. I can force sleep it just fine and it won't wake up all the sudden.

    What can I try to get it to sleep - is it a PMU reset that I need to do? If so, does anyone here from the top of their head remember the trick to do this on an Intel machine? Is it something like unplugging all cables and then only insert the powercable while holding the powerbutton on the back of the computer for a second then letting go?

    Thanks for any help.
     
  2. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #2
    So, it must be something I'm doing because I just reinstalled OS X again with a clean install without copying Time Machine files back like I did the last time and the computer still won't sleep after the default 10 minutes. This is on a bare bone OS X 10.5.6 installation with every update from Software Update. I found the Apple Support site and looked around for the SMC reset page which I found and did a successful reset of the SMC I think, but it's the same. I tried setting the sleep to 1 minute and just sat there waited for the iMac to sleep but it never did - the screen goes black but system is still running.

    I would like to get this resolved so that I can leave my Mac if I'm in a rush and know that the computer sleeps like it's supposed to do.

    Help??

    Edit: I found out what was causing the non-sleep issue; it was my internet sharing that kept the system alive. Airport was not on but the sharing was set in System Preferences. Problem solved.
     
  3. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #3
    Pants! I have the exact same issue on my 24" iMac. The screen can turn off but the machine refuses to sleep.

    I can force it to sleep but it won't do it on it's own. I do not have Internet Sharing turned on.

    Never heard of Antipop, but I'll look into that, thanks.
     
  4. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #4
    Firefox has a tendency to not let the machine sleep. This worked for me when I used Firefox; go to about:config and search for "places" - now at the bottom there is an entry named something like "places.idleload" and a setting of 60000. Set this to 0(zero) and if you have Firefox open the Mac will sleep.

    This is just an idea if you happen to use Firefox3.
     
  5. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #5
    I do indeed use FF3. I changed the setting, made sure both Energy settings were set to 1min, bent over my desk for 1min to listen, but no! I'm afraid that didn't do it.

    I then shutdown FF3 and tried again but still my Mac refusing to sleep.

    I know it's not sleeping, as when I use alt+cmd+eject to sleep, the machine's silent. When it "sleeps" on it's own after 1min, I can still hear the damn thing!

    Thanks anyway.
     
  6. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #6
    Oh, I'm not sure what to tell you next. I just know that it was what did it for me. I also had to relaunch Firefox after the setting change but I got my Mac to shut down perfectly. Maybe you need to reset your SMC? I did this a couple of times because I had no idea what was preventing the Mac from going to sleep. Here's the link if you want to try http://support.apple.com/kb/HT1543
     
  7. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #7
    Thanks. Tried that, but still no deep sleep!

    I was tempted with a new/fresh install of 10.5.6, but I see from your post that it still didn't solve the issue.

    It's an @rse knowing the functionality is there, but unusable.

    Thanks for your help!

    After trying several things on Google, I came across this NMS. I tentatively installed it and it seems to work. My basic understanding is that it periodically checks if your system has been idle for a while, if so, forces sleep. CPU usage seems normal, and haven't noticed anything out of the ordinary.
     
  8. McShizzel macrumors regular

    Joined:
    Oct 29, 2008
    Location:
    Canada
    #8
    I'm having the same issue but on my 2009 Mac Pro, it was sleeping by itself a few days ago but now the screen will shut off but the system remains running.

    I also tried starting my system in Safe Mode to see if that would help but no can do. The only new software I installed in the last few days were: GeekTool, Paragon NTFS, and a demo of CandyBar which I uninstalled.

    Here's a link of someone who's experiencing the same problems but with the 2009 Mac Mini http://forums.macrumors.com/showthread.php?t=673037&highlight=won't+sleep

    I may contact Apple tomorrow and see if I can get a response from them.
     
  9. nickcliborne macrumors regular

    Joined:
    Aug 25, 2008
    Location:
    Nut house
  10. jmpage2 macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #10
    It's definitely a FF3 problem if you are using FF3. Regardless of what energy saver settings you enter, FF3 will sometimes prevent the machine from sleeping depending on what page you have the browser parked on.

    From what I understand FF3 does things like access the hard drives when reloading certain parts of some web pages. You will likely find that the machine sleeps perfectly if FF3 is left open on google.com but will fail to sleep if other sites, such as Apple.com are opened.

    If you do a search on posts by me you'll see a whole thread about this problem with the Mac Mini I recently purchased, along with a link to the bug thread at Mozilla documenting the issue, which the folks at Mozilla don't view as a "blocking" bug for release of FF3.1.
     
  11. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #11
    This application also helps the system go to sleep http://www.dragonone.com/products/macosx/pleasesleep/ - I should have mentioned this earlier.

    Edit. take a look at these pages: This first page is what I got when I went looking for a solution; http://support.mozilla.com/tiki-vie...s_per_page=20&thread_style=commentStyle_plain

    Now this next page is I believe the same that jmpage2 links to in his thread about his Mac Mini;
    https://bugzilla.mozilla.org/show_bug.cgi?id=428565 - take note of comment 53(regarding sleep settings) and maybe 57 too.
     
  12. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #12
    Thanks for the advice. But I even tried closing FF3 and running the same tests, but my iMac still refused to sleep. This may be a valid solution for some people, but it didn't work for me :(
     
  13. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #13
    Thanks for this. I actually uninstalled NMS, ran some above tests and found my iMac had a case of insomnia again. I then installed PleaseSleep (which frankly has a slicker interface, and none of the bulk of NMS), and the iMac sleeps once more.

    I'm not disbuting the error may well be with FF3, but I'd rather use PleaseSleep than start changing default settings with FF. I little out of my depth too ;-)

    Thanks all!
     
  14. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #14
    Good thing that you found a way to make your Mac sleep. Remember to set the "places.frecency.updateIdleTime" setting back to the default value. ;)
     
  15. johto macrumors 6502

    johto

    Joined:
    Jan 15, 2008
    Location:
    Finland
    #15
    Create a new fresh account and test sleep with that. Then you know if its a "global" error or just some program messing with you. :cool:
     
  16. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #16
    I forgot to mention, I already tried that.

    I have my account on the iMac (admin), and I logged out, and logged in as a Guest (if that counts?) and still the same issue. No deep sleeping!
     
  17. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #17
    After a successful couple of days I have now run into the same issue that si77hay has. My iMac won't sleep on its own. I have tried logging in with no startup items(by holding shift while logging in)and as guest setting the sleep to 1 minute and just wait. Nothing happens. Odd behavior indeed. I now run PleaseSleep which cures the automatic sleep.

    I did recently install NetBarrier X5 because of a feeling of insecurity and after a reset I found that the computer wouldn't sleep. Then uninstalled NetBarrier-restarted; the iMac still won't sleep automatically. The screen will go blank after 1 minute but computer is still awake.

    Then thought it must be because I had loaded Camino(read somewhere that a launch of either Firefox or ?Camino? might prevent sleep until restart). Still that wasn't it. I tried taking apart my login list but nothing helps. So, then next step for me is somehow to get on Apple Support forum and complain to see if anyone there can figure out what the deal is.
     
  18. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #18
    Not sure if it helps, but I don't have Camino or NetBarrior installed. I have PleaseSleep solving the issue, but it's an annoyance that it's solving a problem that the iMac should be able to do on it's own.

    If it's of any interest or help, I've just dumped my current Activity Monitor into a text file.
    View attachment Processes.txt
     
  19. Pagemakers macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #19
    I have a brand new Mac Pro 09. 2 days old.

    Tried everything and the damn thing will not sleep automatically all of the time.

    Even scheduled sleep did not work last night.
     
  20. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #20
    I've stopped wasting time trying to solution this issue. PleaseSleep works fine for me.
     
  21. Pagemakers macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #21
    Yea I have just installed that and it seems to work fine. However Apple needs to fix this (feedback left).

    Do you know how to remove the please sleep taskbar icon?
     
  22. allan.nyholm thread starter macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #22
    I think you can make transparent GIFs(inside the resources folder) and then make it seem like it's not there except for a blank space.
     
  23. Pagemakers macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #23
    Thanks for that tip. Currently I have an open Applecare ticket to see if we can resolve the issue.

    Personally I think it's a bug in the OS. Even an archive/install did not fix the problem.
     
  24. jmpage2 macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #24
    I'm wondering if a fresh restore from the install discs corrects this problem. In my case the issue is definitely FF3 related, as completely quitting FF3 always gets my Mac Mini back to sleeping.

    I have a Radeon 4850 equipped iMac 24" on order, have to see if that one has sleep issues as well.
     
  25. jmpage2 macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #25
    I thought I'd resurrect this thread as I've uninstalled FF3 and still had sleep issues with Safari 4.

    If Safari 4 is open on certain web pages then the iMac will not sleep. Closing Safari down more or less fixes the issue 95% of the time.

    Can anyone else confirm having sleep issues with newer Intel iMacs and Safari 4?
     

Share This Page