iMac 24 mid-2010 with ram-related issues.

Discussion in 'iMac' started by michael.travan, Dec 5, 2013.

  1. michael.travan macrumors newbie

    Joined:
    Dec 5, 2013
    #1
    Hello to the forum, this is my first post here. I'm from Italy so I hope you'll forgive my bad english.

    Lately I'm having some serious issues with my mid-2010 iMac. Everything started when i freshly installed Mavericks (by freshly I mean an "erase&install"). Soon after that my mac started panicking randomly, so i checked disk with Disk Utility and the "incorrect node" error message appeared. DU was unable to repair disk. So i smelled something wrong and went straight to another fresh installation, from a usb drive, after repairing disk from there (it was successful, this time). No luck tough, a generic error stopped the installation and when i went back to DU (from mavericks installation - usb) the same error showed up ("incorrect node").

    After that i scouted the web for possibile solutions, and i tried almost everything:
    - Resetting PRAM
    - Resetting NVRAM
    - Disk Warrior
    - Different OSs (including SL, L, ML).
    - Single User Mode, Safe Boot
    - Target disk mode (to repair permission/disk)
    - Swapping to another HD (that i knew it was a functioning one)

    No luck. I was desperate. Then I tried one last thing, found on a dark and scarcely populated forum. Removing a Ram bank ( I had 2, 2gb each).
    And -tadaaaa- Mavericks installed like a charm with a 2gb Ram card.
    BUT -and here's my current issue- now i can't mount more than 2gb, every time i try to put on my brand new 8gb single-bank Ram card, the system boots up, runs for a while, and as soon as I open more than two programs, screen goes black and reboot. If I just let it quiet without touching it, it stays up for hours.
    Same results with 2x 2gb original ram banks.

    I am quite desperate, as you may guess.
    Any hints on what's going on ?
     
  2. Twimfy macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #2
    Somehow I'd try to clean that ram slot if I were you, there's a possibility something has gone wrong with that original ram slot (it may have oxidised or something) and left crap behind.

    That's all I can think of beyond the logic board being defective.
     
  3. michael.travan thread starter macrumors newbie

    Joined:
    Dec 5, 2013
    #3
    Thank you for the reply. I'm horrified by the thought that the logic board may be broken. But - just asking - shouldn't it give some other errors more than just not supporting 2gb+ of Ram ?
     
  4. michael.travan thread starter macrumors newbie

    Joined:
    Dec 5, 2013
    #4
    Update

    Just to be sure, I returned my brand new ICE Memory 8gb ram to the shop I bought it from, and had it replaced with a new one. Still no luck, my iMac gives the same error during start up. I cannot post the log here, since it appears during boot and I'm unable to copy. Any other hint ? Could it be something related to EFI ? Another strange thing is that it doesn't let me boot from a USB key with Snowleopard installation. It lets me boot from Lion, Mountain Lion and Mavericks, with the same Usb drive.
     

Share This Page