iMac 27" 2017 HDMI / DP Issue

Discussion in 'iMac' started by jmack007, Jun 11, 2017.

  1. jmack007 macrumors newbie

    Joined:
    Oct 18, 2016
    #1
    Not sure if this is the place, but maybe someone has an idea why this setup isn't working.

    I have a USB-C -> DP Cable and a USB-C -> HDMI 2 cable. When I use these cables on my 2017 Macbook Pro 15", they work great. 4k @ 60hz without an issue. However, when I use these same cables on my new iMac 2017 5k 27", nothing. The monitors (tried 3) are not detected and nothing flickers.

    Now, if I use an Apple USB-C Digitial AV Multiport cable on the same iMac, it works fine over HDMI, but ofcourse I can only get 4k @ 30hz which I cant stand.

    Any ideas why my these cables work on my MacBook but not on the iMac?
     
  2. jmack007 thread starter macrumors newbie

    Joined:
    Oct 18, 2016
    #2
    An update. I spent an hour with Apple and they couldn't figure it out either. Here are a few other things I have found out:

    1 - When I plug in the USB-C -> Display Port adapter into the iMac, nothing changes at all in System Report. If I plug it into the MacBook Pro, it shows as a USB 3 Billboard Device.

    2 - When I plug the USB-C -> HDMI (trendnet) adapter into the iMac, it does show in System Report, but as a USB2 device, when I plug it into the MacBook Pro, it shows as a USB3 device.

    Can someone with a 2017 iMac 5k please take a screenshot of the USB section of their system report and post it here?

    I am curious if there is an issue with the USB 3 bus, because I find it odd that there are only two bus' listed under the USB device tree, when the MacBook Pro shows three bus'.

    [​IMG]
     
  3. diabora macrumors newbie

    Joined:
    Jul 30, 2012
    Location:
    DK
    #3
    --- Post Merged, Jun 15, 2017 ---
    Any news on this issue?

    Please chime in, if any of the lucky ones that has their 2017 iMac already, has been able to connect a secondary display via usb-c to HDMI adaptor.
     
  4. SCMedic macrumors regular

    Joined:
    Feb 8, 2008
    #4
    Just bought a USB-C to Displayport cable and my brand new iMac doesn't detect my Dell Ultrawide. WTF Apple. First the RAM problems and now the cable?
    --- Post Merged, Jun 15, 2017 ---
    Quick update, my USB-C port had an extra click that required a hard push to really seat. Fixed the problem for me.
     
  5. assoemitro macrumors newbie

    Joined:
    Jun 6, 2017
    #5
    Can anybody check both USB-C port? I remember somebody test that the left one is different from the right one when testing it as target display.
     
  6. Glockworkorange macrumors 65816

    Glockworkorange

    Joined:
    Feb 10, 2015
    Location:
    Chicago, Illinois
    #6
    Whoa, what are the RAM problems with the new iMac?
     

Share This Page