Imac 27" can't see camera with USB extender

Discussion in 'Digital Photography' started by hedho, Dec 6, 2012.

  1. hedho macrumors newbie

    Dec 6, 2012
    For the first time I've taken my iMac27"out on a job with the same
    software I run on my iMac24" & MBP 17".

    My Canon 1ds Mk3 & 5D2 both run using the tethered system in
    Lightroom 4.2 with no problems, using a 5m active USB extender.
    They work all day long every day. But the 24" is running a bit slow with LR4.2, that's a WHOLE other issue (thanks Adobe).

    So my problem is that, with the iMac27, the 1dsmk3 is not recognised by
    the computer or LR4 when using the cable extension. BUT, if I use
    the standard Canon length cord (approx 2 ft) it works fine.
    So probably some power issue with the USB port?

    I tried it in every port, and the same result, except the port closest to the headphone jack made the screen/computer freeze, when the camera was plugged in.

    I also did a computer restart , Cmd-Opt-P-R to reset the PRAM etc.
    Still no luck. I tried a different 5m active extender, and they same thing happened. I even had an error code come up on my camera "ERR70"
    which can relate to a whole lot of image issues.

    Can anyone let me know what I can do to test why the USB ports may have some confliction with the USB extension?

    Geoff (Auckland , NZ)
  2. ijohn.8.80, Dec 6, 2012
    Last edited: Dec 9, 2012

    ijohn.8.80 macrumors 65816


    Jul 7, 2012
    Adelaide, Oztwaylya.
    Only suggestion I have is to try it with plugging it into a powered USB hub which is then fed to the iMac. Let us know if this works. It resolves this sort of issue for me with other USB devices like DJ, midi and video controllers.


    Another suggestion or query for you actually Geoff. You are using the DC power pack to power your extension aren't you? An active USB extension only properly works when it's powered. My suspicion is that the camera is trying to get charged and this is too much draw for the cable length you're using.

    As I said above, I have to then plug this into a powered usb hub to get my controllers working from a distance.
  3. scottgoh macrumors member


    Oct 23, 2012
    i think i read it somewhere that there is a limit to the usb wire length and as the wire gets longer, power are loss.
    the shorther the cable the more power that can be transmitted to the unit.

    try replacing the usb cable. hopefully, that helps.

    I may be wrong but just my thought.

    ijohn.8.80, i am from adelaide too. nice to meet u.
  4. ijohn.8.80 macrumors 65816


    Jul 7, 2012
    Adelaide, Oztwaylya.
    Welcome to the group. They are very friendly here. No egos, no dictators! :)
  5. nelupasilk macrumors newbie

    Aug 17, 2012
    I have used Cat5 USB 2.0 Extender solutions in the past and they work well. I am not sure about the active extension cables. It might the quality of the cable you are using.
  6. Designer Dale macrumors 68040

    Designer Dale

    Mar 25, 2009
    Folding space

Share This Page