iMac 27" i7 2.93 slower then old MBP. Disk accessing data all day...

Discussion in 'iMac' started by coral, Dec 3, 2010.

  1. coral, Dec 3, 2010
    Last edited: Dec 3, 2010

    coral macrumors newbie

    Joined:
    Aug 13, 2007
    #1
    Hello!

    Got my new iMac 27" i7 2.93 for three weeks ago. Everything was kind of fine but now everytime i boot it starts to write to the disk, and since you really can hear when the machine writes to the disk, it's obvious when it does it. The disk is a WDC WD1001FALS-40Y6A0

    - I turned of spotlight indexing, rebooted, 30 minutes later it was still writing like there was no tomorrow.

    - Checked Console.app, just Google Chrome trowing messages (which is running slower then on my old MBP Santa Rosa 5400 rpm).

    - Ran disk utilty repair permissions, still no luck.

    - Used Lingon to get rid of **** at startup, still no luck.

    - No disk encryption.

    The bottom line: The machine runs slower, boots applications slower and functions slower then my old MBP 2.4 ghz Santa Rosa 2007 with a 5400 rpm hdd. I tried to run a blu ray mkv from the internal disk, stuttered as hell and didn't work despite VLC being the only open application. Then i ran it from an external 5400 rpm Firewire drive and it worked flawlessy. What is up with this? Shall i reinstall and empty my disk?

    Is there any software for checking what applications is currently writing to the HDD?

    Screenshot from my activity monitor
     
  2. viizi macrumors regular

    Joined:
    Dec 2, 2010
    #2
    Do you have windows installed on a partition? I had Windows on a partition with a bunch of games and it tries to index all of windows and goes for agesssssss. I don't know how to stop it but I removed windows because I hardly used it and it stopped doing it.
     
  3. coral thread starter macrumors newbie

    Joined:
    Aug 13, 2007
    #3
    I have Windows installed but i have turned of Spotlight indexing for everything.
     
  4. nOw2 macrumors regular

    Joined:
    Sep 1, 2009
    #4
    Check Activity Monitor to see if you can detect what is causing it - in your screengrab you've hidden processes ('My Processes' in the top right).

    Run 'vm_stat 1' and 'iostat 1' in the shell, it'll output some useful IO related data which you might post here after capturing a few minutes worth. It's possible for instance that the machine is constantly swapping as some process is using a lot of memory.

    Also 'ps aux' output would be useful to see.

    If there is no obvious cause, then I'd say take a time machine backup and put a clean install on. If that still doesn't work, then possibly it could be hardware related. Else, restore the time machine backup and continue looking at software.
     
  5. coral, Dec 3, 2010
    Last edited: Dec 3, 2010

    coral thread starter macrumors newbie

    Joined:
    Aug 13, 2007
    #5
    I have 16 gb of ram in this machine so swapping seems unlikely (especially when the machine is newly booted and no applications are up). Going to gather some data with the commands. Be back!
     

Share This Page