Imac 27" internet connectivity issues

Discussion in 'iMac' started by LindseyDarragh, Feb 26, 2010.

  1. LindseyDarragh macrumors newbie

    Joined:
    Aug 12, 2009
    #1
    So I just purchased a 27" imac from the apple store 2 days ago. I was previously running a late 2008 intel Imac. I copied everything from the intel imac to a my passport 1TB hard drive and used time machine to sync my 27". I have run into a couple issues with this.

    First, none of my music from itunes was copied over and it says that my library is corrupt. Thats frustrating but I dont think that will be too difficult to fix. The bigger problem is with internet connectivity. The night I firs set everything up my internet worked great. Yesterday though I noticed I was not able to connect to my wireless network at all but the modem was showing me as connected. I called my ISP and of course they had me reset everything and said something like the router remembers the last device it was connected too. Well after having reset everything my internet connection works to an extent. The router isnt working at all and my husband thinks it is fried. But when I use an ethernet cable connected directly to the imac I get some connectivity. I can use just about everything on my computer which requires internet access except safari or explorer. Skype works fine, online poker sites work fine, mail client works fine. It just seems to be browsers. I first realized the problem when running windows 7 on bootcamp but I get the same issue when in osx. What is the problem?
    Is it related to me trying to update from a time machine from the intel mac or is it just an inherent problem with my 27"?.... btw when I connect my macbook pro via ethernet everything works great. thats what im using now. Thanks in advance for the help.
     
  2. LindseyDarragh thread starter macrumors newbie

    Joined:
    Aug 12, 2009
    #2
    bump

    I have tried every bootcamp update i can find. I even completely deleted and reinstalled my windows partition. still nothing :(
     
  3. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #3
    I think it's the Time Machine backup you migrated from. Did you use Time Machine to create a backup or did you just copied everything into the drive? Do the wireless internet work fine in other computers? Have you tried diagnosing the problem with e.g. Safari (click the network diagnose or smth like that)?
     
  4. LindseyDarragh thread starter macrumors newbie

    Joined:
    Aug 12, 2009
    #4
    progress

    I deleted everything and started from scratch. REstored the imac from the backup, created a new windows partition and reinstalled windows 7. I have had some progress but I am still not quite there. Everything now works correctly in osx. I read somewhere to reset the PRAM? I'm not totally sure what that means but that corrected the problem in snow leopard. After reinstalling windows 7 I downloaded the apple drivers and upgraded to bootcamp 3.1 as the tutorial suggests. That solves the problem. But after I restart I always have to reinstall the 3.1 update. Its like my computer just keeps forgetting that ive already installed the update but each time after reinstalling everything works fine. I currently have the update saved on a flash drive so that I can quickly reinstall but I would certainly hate to have to do this each time I want to use my windows partition.

    Thanks
     

Share This Page