iMac 27 late 2009 sleeps after boot + fans wont spin

Discussion in 'iMac' started by Eidan, Apr 7, 2015.

  1. Eidan, Apr 7, 2015
    Last edited: Apr 8, 2015

    Eidan macrumors newbie

    Joined:
    Apr 7, 2015
    #1
    Hey guys,

    I've just swapped the superdrive for a Samsung 120 gb SSD wich I'm using as main hard disk with Yosemite + the old 1 tb (no fusion). Everything works fine except two things: 1. the imac boots and after 4 seconds it sleeps automatically. If I wake it up everything is fine and it won't happen anymore. 2. fans won't spin automatically they always stay at the minimum. I did a hardware test and there are no error. If smc fan control I can set the fans to whatever I want. What's the problem? I've connected the dvd sensor to the ssd alluminum case, no problem it detect temperatures. I restored a time machine backup...maybe is it the cultrip?
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    For the sleeping problem, try a PRAM reset. As for the fans, have you done any intensive tasks to trigger them to spin up? You may have mistook the hard drive noise for fan noise before you put in the SSD.
     
  3. Eidan thread starter macrumors newbie

    Joined:
    Apr 7, 2015
    #3
    Thanks for the reply. :) I already did the a PRAM reset + a SMC reset. Nothing change. I'v done intensive tasks and the fans are at minimum speed. I will try to boot from the old 1 tb drive to see if it is a software problem.
     

Share This Page