iMac 27" wifi problems

Discussion in 'iMac' started by LikexTides, May 1, 2013.

  1. LikexTides macrumors newbie

    Joined:
    Aug 19, 2012
    #1
    So, I just received my iMac yesterday in the mail. I have the i7 3.4GHz/8GB/1TB/680MX variation. I love the machine so far. It's my first iMac. I have a MacBook Pro, and I have since 2011... Anyway, this leads me to my question.

    The iMac (and MacBook) both lose wifi signals quite often. I'm assuming since it's happening to both, my router (D-Link DIR-655) doesn't agree with the computers. Could anyone offer any input on this? I've searched high and low and I can't seem to remedy the problem and it's driving me absolutely insane.

    I've tried reseting the router and our modem, several times. It seems to fix it for a little while but the problem always comes back.

    Thank you for taking the time to read this, and for offering any help!
     
  2. Constrict macrumors newbie

    Joined:
    Dec 13, 2007
    #2
    I wish I had an answer to this, but I have the same problem. Ive got a late 2009 iMac and have had this problem since I bought it. Its not the router in my case since all my other devices work fine and never lose connection.

    So a +1 from me.
     
  3. Nuke61 macrumors 6502

    Joined:
    Jan 18, 2013
    Location:
    Columbia, SC
    #3
    Switch channels on your router and see if that helps. Shift it by 2 channels and run if that way for a while.
     
  4. LikexTides, May 1, 2013
    Last edited: May 1, 2013

    LikexTides thread starter macrumors newbie

    Joined:
    Aug 19, 2012
    #4
    Honestly I have absolutely no idea how to do that haha.

    EDIT: I figured it out. Changed the channel. Let's see if that helps.
     
  5. nhanda macrumors newbie

    Joined:
    Oct 12, 2011
    #5
    I had the similar issues where the wifi speed was very slow on my new imac.
    I changed the channel to 8 on my router and got the issue resolved.
     
  6. bmcgrath macrumors 65816

    bmcgrath

    Joined:
    Oct 5, 2006
    Location:
    London, United Kingdom
    #6
    Wifi channels tend to get clogged up quite easily if you're in an area with lots of other routers.

    Wireless mice and keyboards can also affect along with fridges and microwaves.
     
  7. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #7
    Run wired GigE cables to the iMac if you can. It's much faster & more reliable than any WiFi connection.
     
  8. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #8
    If that does not work, another thing to try is updating the DNS settings your ISP uses. That is another frequent cause of issues. To change the DNS settings please read:

    http://macs.about.com/od/networking/qt/configure-your-macs-dns.htm

    If that doesnt help there are other things to try, just post back with progress reports.
     

Share This Page