iMac 8,1's Graphic Card Dead......?

Discussion in 'iMac' started by imacimac, Oct 20, 2011.

  1. imacimac, Oct 20, 2011
    Last edited: Oct 20, 2011

    imacimac macrumors newbie

    Joined:
    Oct 20, 2011
    #1
    Hi everyone! My iMac's screen just wouldn't turn on 2days ago...I tried everything that I can do, it seems like the logic board works fine, as I was able to use my macbook to remote control it, I went to the "About This Mac" to check the hardware info, the graphic card (NVIDIA GeForce 8800 GS 512MB) is missing, thinking the graphic card is done?....Any sugguestion or comment or experienced the same problem?

    Thanks!

    here's some screen shots
    [​IMG]
    [​IMG]
    [​IMG]
     
  2. AlphaDogg macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
  3. imacimac thread starter macrumors newbie

    Joined:
    Oct 20, 2011
    #3
    24" iMac (Early 2008)
     
  4. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #4
    @AlphaDogg: iMac 8,1 is the model identifier for the "Early 2008" 24" iMacs.

    @imacimac: I have the exact same hardware as you do, but I'm still running OS X 10.6.8. I wish I could help you but I don't really know the answer. I would guess that it's the graphic card and not the display. You have the "ATI Radeon HD 2600 Pro" card, too? I sure hope mine doesn't die...

    Regards,
    Brian33
     
  5. iMacC2D, Oct 20, 2011
    Last edited: Aug 12, 2017
  6. imacimac thread starter macrumors newbie

    Joined:
    Oct 20, 2011
    #6
    Mine is NVIDIA GeForce 8800 GS 512MB, but I just ordered the graphic card from ebay, will see how it goes, but seems like lots of people who owned iMac8,1 got the same problem lately, as 5 peoples ordered the same card from the same seller I just ordered recently...Either it back to alive or not, gonna get the next generation iMac, as I got over 900GB photos in the aperture library, need a faster CPU to deal with it...But for sure will be great it back to alive, as I can use it for lighter stuff or entertainment.
     
  7. Ed85 macrumors newbie

    Joined:
    Nov 30, 2011
    Location:
    London, United Kingdom
    #7
    Nividia 8800 gs issues

    Hi there,

    I know it has been a few months since this post has been active, but it caught my eye while Google searching for something else and I wanted to post as I've had this problem a couple of times over the past few months.

    I have an iMac 8,1 (early 2008), 24" with the Nvidia GeForce 8800 GS. It turns out there are a lot of complaints this year about the 8800, as apparently it wears out over a few years, and replacements (clearly refurbished, since they don't make the 8800 brand new anymore) fail quickly too.

    I had my GPU replaced a few months ago, and it failed within a month. I paid about £200 having just been out of AppleCare cover period. When I took my iMac back again because of the same issues (freezing and graphical anomalies) the GPU and also the logic board were replaced, both free of charge this time (90 day warranty on original replaced GPU). No issues yet, but we'll see.

    I think it's a known issue, but not QUITE big enough to have warranted a recall, so just keep getting replacements. If it happens again (third time) I'll see if they just replace the whole iMac and pay the difference for an upgrade.

    INTERESTING NOTE: The tests at the Genius Bar both times showed a missing GPU Proximity sensor. Clearly burned out / melted off etc.
     

Share This Page