iMac - Airport drops wireless connection

Discussion in 'Mac Basics and Help' started by n.contemporary, Aug 21, 2008.

  1. n.contemporary macrumors newbie

    Joined:
    Mar 12, 2008
    Location:
    Canada
    #1
    Hello,

    I have searched the macforums and while i have found an abundance of similar questions RE: Airport dropping wireless internet, most of them seem to concern macbooks or macbook pros


    This is my problem,

    I have a 20inch 2.16 GHz Intel Core 2 Duo iMac using wireless internet via a Linksys WRT150N router and the internet, more often than not, never works properly.
    This is a regular pattern of what happens with my internet:

    1) I will be on the internet, it will be working alright though not optimally (ie: there will be full bars but the internet is so slow, or it will keep fluctuating between one bar to 3, to 4, and back to 1) Sometimes the internet will (briefly) work well and then it will revert to being slow and inconsistent

    2) After being connected for about 10, 15, or 30 minute intervals (give or take) airport will randomly drop the connection even though my network is still listed in the drop-down list. Some days it will drop connection every few minutes which is insanely frustrating.

    3) After re-selecting my network/attempting to reconnect it will take minutes before i am able to use the internet again (in System Preferences > Network > under airport it will say 'unable to connect' or ' airport has a self-assigned ip and may not be able to connect') ie: airport will have a red or amber coloured light for 2-5 minutes before it finally turns green and is connected.

    4) I am now back on the internet, connected, and with a decent (or slow) connection then the pattern starts over again: either internet becomes slow or is dropped completely.


    My router is on a different level of the house than my imac (and i know people say interference may be an issue here) however, i use my ipod touch sitting at my imac desk (or within the same room) and have flawless connection - incredibly fast loading speed and the connection rarely drops (it may drop if ipod goes to stand-by and i turn it on again, or if i am looking at one site for a long time and then go to open a new page) the ipod touch also connects to the internet much faster than my imac


    Im sorry for writing so much, I am just trying to be as specific as possible in order to get the most accurate advice and responses.


    Any suggestions or comments would be much appreciated.

    Thank you.
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Sounds like either a loose card or it being interfered with. Have you applied all Driver and Firmware updates for the Airport Cards?

    TEG
     
  3. n.contemporary thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    Location:
    Canada
    #3
    As far as i know, everything is up to date.
    (however I am just going by apple's software updates . . .where should I look to confirm airport updates?)




    On google i see a lot of people have a problem with slow wireless in Mac OS X 10.4.11 (and hear leopard isnt much better)

    Any more suggestions or should i look into getting and Ethernet cable?

    I am just irritated that the only way i may be able to have fast, reliable internet is to be plugged in via ethernet. Im upset that my parents ancient (like 256mb of ram, 40GB Hard Drive, Circa 1999 or 2000) computer loads pages faster than my imac as does my ipod Touch.
     
  4. n.contemporary thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    Location:
    Canada
    #4
    I went to the linksys website and downloaded the new firmware for my router.

    However, this did not solve my problem.
    I dont know if the inconsistent wireless speed / constant drop outs are a linksys problem or an apple (airport card) problem.
     

Share This Page