iMac Airport problem

Discussion in 'iMac' started by Matetus, Aug 25, 2012.

  1. Matetus macrumors newbie

    Joined:
    Aug 25, 2012
    #1
    I have a recurring problem with Airport on my iMac(Snow Leopard 10.6.8, Build 10K549), every 6 months or so a problem occurs in the same manner:
    Stage 1:
    Connection to home network(WPA2) drops every now and again(usually once every 2 days) and continues to do so for roughly 2 weeks
    Stage 2:
    Can't connect to home network, this usually lasts for a week
    Stage 3:
    Can't connect to any wifi network(WEP,WPA2...)

    This is the 3rd time it's happening and it's to say the least, frustrating.
    I tried erasing all known networks and restarting many times, but to no avail.
    I usually format the entire HD and put a clean install of Snow Leopard and I'm fine for another 6 months, but it's irritating, every 6 months i have to put every work I have on hold for a day or so.

    Does anyone have any clue how to fix this or has even heard about something like this?:confused:
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    What kind of router...and have you tried restarting the router?
     
  3. Matetus thread starter macrumors newbie

    Joined:
    Aug 25, 2012
    #3
    Thomson st780, but i don't think that the problem is with it, because i can access the wi-fi network without problems from my laptop(win 7)
     
  4. btbrossard macrumors 6502a

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #4
    I'd try rebooting the router when this happens to see if that helps.

    Also - when this happens can you connect to the internet with an ethernet cable (if possible)?
     
  5. Matetus thread starter macrumors newbie

    Joined:
    Aug 25, 2012
    #5
    I tried rebooting it too, but, nothing :/
    And it's not possible for me to connect using an ethernet cable.:(
     

Share This Page