iMac airport problem:

Discussion in 'iMac' started by MrT8064, Dec 12, 2007.

  1. MrT8064 macrumors 6502a

    MrT8064

    Joined:
    Jun 7, 2006
    Location:
    UK
    #1
    Hi, i have just bought a new aluminium iMac, and when trying to connect to my home wireless network (unsecure) often it just wont saying 'Error connecting to airport network.....' if i turn airport off and on again several times, this fixes the problem, but next time i return from sleep or turn the system on; same thing happens.

    what can i do?

    (p.s. my macbook pro, and iPhone have never had any problems)

    is it time to take the iMac back?
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    I have found this to be an intermittent problem with Leopard and some types of wireless networks/security settings.

    For example on my home network with WEP it had that problem and it occurred everytime and would sometimes take a reboot to get working.

    Changed the network to MAC filtering + no password and it connects most times but still I have the problem from time to time.

    At Uni on WPA enterprise I have no such problem.

    In Tiger I had no such problems then I upgraded to Leopard and these issues started - therefore I am concluding it is a Leopard Problem.
     
  3. MrT8064 thread starter macrumors 6502a

    MrT8064

    Joined:
    Jun 7, 2006
    Location:
    UK
    #3
    hmmm, i'm having these problems... but i am running Tiger (waiting for leopard disk)

    its really anoying!
     
  4. LaJaca macrumors regular

    LaJaca

    Joined:
    Nov 23, 2007
    Location:
    Near Seattle
    #4
    I have a Linksys wireless router originally set up with a Vista laptop for my home network. Getting my iMac to connect was not easy, but only because of settings I knew nothing about in the Linksys. Took a technical assistance call to the Linksys folks in India to change some protections in the router - now works like a charm.

    I have Leopard on my iMac.
     

Share This Page