iMac Airport Question:Versalink 327W

Discussion in 'iMac' started by Finnxeon, Oct 1, 2006.

  1. Finnxeon macrumors regular


    Aug 20, 2006
    ok. so i know this has been discussed before but i was unable to find the original thread....

    I just got my new iMac and i love everything about it, but i noticed that airport is unable to function with my Versalink 327W router.......

    I seem to remember this was a problem with core duo iMacs as well, but i don't seem to remember whether a fix was ever found......

    So my question is, will my iMac be restrained to an ethernet cable till i can buy a new router, or is their a fix to this problem that i don't know about.....

    either way it's not critical, i really don't mind being plugged into the router, although i would like to get rid of some wires but i can deal.....

    any info appreciated! Thanks!:)
  2. radakaal macrumors newbie

    Sep 12, 2006
    I have verizon dsl with a versalink 327w. It works fine with my new imac core2duo. The imac found the wireless router and connected with no problem.
  3. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    There may be different versions of the 327W, but I tried everything I could with my i7" Core Duo iMac and was unsuccessful. The iBook works like a charm. In the end I just disabled the wireless on it and added a WRT54G as a WAP.

    radakaal can you post your firmware rev on the Westell mine is

    Model Number      	    A90-327W15-06
    Serial Number     	    
    MAC Address      	    
    Software Version 	    VER:03.00.63a
    Software Model   	    4 Port Gateway
    Description         	    WireSpeed Data Gateway
    Boot Loader        	    VER:03.00.63a
  4. radakaal macrumors newbie

    Sep 12, 2006
    I have a B90-327w15. Rev D. Version 03.02.00a. Manufactured 3/2005.
  5. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    Lovely. So I guess the problem is reserved for those of us with early Westells.

  6. radakaal macrumors newbie

    Sep 12, 2006
    Did you check to see if there is a firmware update?
  7. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    All the time. Nothing ever shows up. The fact you also have a hardware rev makes it even less likely that there will be an upgrade. Guess this means I should just take Verizon up on their recent FIOS offer.

  8. radakaal macrumors newbie

    Sep 12, 2006
    Maybe you could use a separate wireless router plugged into the versalink. Verizon worked for me with a zoom modem and a dLink wireless router with my pc's. I didn't have the mac then so I don't know if it would have been compatible.
  9. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    That's what I do. :p

  10. Finnxeon thread starter macrumors regular


    Aug 20, 2006
    i have a rev. f, so that is really not the case, which is rather unfortunate, because now i am really confused...w/e

    does anyone have any suggestions for a "cheap" router that will work with my iMac?

    *Cheap because i just spent all my money on my iMac and have limited funds lol

  11. sublagga macrumors newbie

    Nov 1, 2006
    Firmware Update Available:

    Orig post:
    I have been looking for an answer to the problems with using an Intel Mac with the Westell 327w router provided by Verizon for several months and know that others are also.

    Tonight I found a firmware upgrade buried in Verizon's support pages that fixed it. I now connect without any problems, and even seem to have better speed and range.

    The upgrade can be found here:

    I have talked to several techies at both Apple and Verizon, and no one seemed to know about this upgrade. Hopefully this post will help someone!
  12. tsptsp macrumors newbie

    Oct 16, 2007
    Versalink 327W FIX!!

    So i have a intel G5 and have had major problems with the Versalink 327W router. BUT NOW I HAVE THE ANSWERS TO FIXING IT!!! What you need to do it log into your Versalink 327W wizard( Go to maintnence, then click on update device. Then go to "". Download the update to your desktop and choose this file in your "update device" page in the wizard....and update it. NOW GET THAT AIRPORT RUNNING!
  13. Throughhisgrace macrumors newbie

    Dec 31, 2007
    Lost... :-/

    Balamw, this is directed towards you... I notice that this thread was started over a year ago, I hope you (or someone) can still help!

    I just received a MacBook for Christmas and had no problem connecting to three others' wireless networks while I was away... but have just now arrived home and have no idea why it will not let me connect to my own.

    If it helps to know, I have Verizon DSL with the modem that you all have been talking about: Westell Versalink Model 327W.

    My MacBook is recognizing that there is a wireless network available (that is indeed mine)... which just happens to be the serial number for my modem. But, it is being stubborn and will not connect for some reason. It tries to for less than ten seconds and then says the connection has timed out.

    My network is not secure... I have tried turning it off, waiting a few seconds, turning it back on, and trying it again. But, that does not work.

    I have tried to follow your forums, but I am lost and I need some help figuring this out in the simplest words possible... :). This is my first Mac and I do not understand the DSL enough to know the terms and all. I would greatly appreciate any help!
  14. balamw Moderator


    Staff Member

    Aug 16, 2005
    New England
    I no longer use the Versalink, so I can't really be of much assistance. (Verizon put in FiOS in my neighborhood a while back). But, I'll reply to bump the thread in the hopes that someone else can answer.

    You symptoms are very different from the issues we were describing earlier in the thread as the Versalink network would not even show up in the Mac. The only thing I can think of that might be some help is the usual hotspot diagnostics.

    Turn off encryption, make sure that works.
    Try entering the password/shared secret in a different way. Hex vs. ASCII, etc...

  15. NewMacUser1000 macrumors newbie

    Jan 2, 2008
    Fixed the Versalink 327W problem

    Throughhisgrace: We had all of the same problems you did. We did the following for our new imac, and everything worked just like advertised. 1) downloaded (directly) the file "" to whatever machine your modem is hooked up to. 2) Open your modem "" 3) click the "Maintenance" button and the "update device" in the drop down menu 4) click the "Local Update Now" button 5) Select the location you stored the downloaded file from step 1 6) Wait until everything is done (took a few minutes for us) Hope this works for you. Good luck and thanks to the others in this thread that provided the firmware update location.
  16. lentang macrumors newbie

    Jan 9, 2008
    Firmware update worked using Firefox, not Safari

    Thank you so much for the link to the firmware update!! I've been unable to connect for weeks until I saw this thread. For me, uploading the update didn't work with Safari but did work with Firefox..
  17. nglovett macrumors newbie

    Mar 23, 2008
    MacBook Air + VersaLink 327W

    Hi all,

    Thank you very much for this discussion thread, and the download link to the mysterious VersaLink update, which solved my problem as well. I scoured the web and could not find any equivalent official or documented downloads through either Westell or Verizon.

    For the record:
    - Brand new MacBook Air
    - Mac OS 10.5.2
    - Verizon-provided Westell VersaLink 327W

    Unsecured wireless network functioned perfectly well for various other PCs and older macs in the house, and the MacBook Air has not had any trouble with wireless elsewhere.

    AirPort could see the network, but could not join. Connection timeout. Console:

    Mar 23 10:23:04 ... airportd[146]: Error: Apple80211Associate() failed -6
    Mar 23 10:23:04 ... System Preferences[107]: Error: airportd MIG failed = -6 ((null)) (port = 43123)
    Mar 23 10:23:04 ... System Preferences[107]: Error joining ...: Connection timeout (-6 timeout connecting)

    Using the download described above and " > Maintenance > Update Device > local update now" the problem went away immediately.

    MD5 (a90-327w.upg) = 4a71f583da25a5250c46bdca2b8b3138

    I have no idea if this is actually the correct/latest firmware for my particular VersaLink model, or how I would find out, but it got the job done and (so far) hasn't broken any other network connections here.

    Thanks again!

  18. variable229 macrumors newbie

    Mar 27, 2008
    Thank you so much for writing this up.. i was so annoyed all morning after doing the Leopard update to 10.5.2 i thought i broke my macbook pro wireless driver or something.

    It turned out to be a firmware problem with the Westell 327W. I downloaded that file and updated to VER 03.02.01 and now my macbook is back alive and wireless again!

  19. jim2100 macrumors newbie

    Apr 18, 2008
    Westel Firmware and Airport

    I gave up trying to update the Westell 327W firmware thru my macbook pro, I hooked up a PC instead.
    After updating the firmware I was able to connect my macbook pro 17" thru airport again.
    Borrow a PC if you have to, its worth it
  20. TryMe007 macrumors newbie

    Apr 26, 2008
    Ready to destroy my MacBook..

    I have a Black MacBook
    Im running Leopard 10.5.2
    And I have a b90-327w15-06 versalink...

    Up until 2 days ago my computer was working fine. I try to connect to my wap today and "Connection timeout" Now this has happened a couple times with 1 of my access points but a day later im always fine to connect again. Not this time, I can't connect to my access point. I installed the update given on this website updated it and still connection timeout. im seriously truely ready to smash this computer into a 1000 pieces. nothing I do will work, I tryed to switch to wpa as well. no luck.


  21. rwATR macrumors newbie

    Nov 25, 2008
    Thank you.

    I never thought a stranger could love another group of strangers so much.

    I have been battling with this problem since June of '08. That makes it 7 months and I haven't found this site until today. I downloaded the firmware update per the instructions above and worked without a hitch (after I restarted my iBook G4 running Leopard).

    Seriously...thank you so much. I was about to give up and go buy a new modem/wireless router.
  22. cynikal macrumors member

    Aug 12, 2003
    confirmed, my macbook pro connected immediately after loading the new firwmare/rebooting the dsl router..

    thank you so much for your help, now i have something to give thanks for on this thanksgiving :)
  23. eugeative macrumors newbie

    Dec 4, 2008
    .upg file?

    how i open the .upg file? i recently downloaded the firmware upgrade from the link you guys provided (thank you, btw!) but when i open it it says that it can't be opened?

    is there something else i'm supposed to do when i download the upgrade?
  24. MacGnG macrumors member


    Jan 24, 2009
    to use the upg to upgrade: log into the router settings and then select the upgrade, manually upgrade the firmware by selecting the file. select the upg file and let the router do its thing... it will take upto 5 minutes or so for the router to reset and everything to load etc....

    thank you mr. applecare for your help... where ever u are :)

    any now i have a new forum to help me with my new macbook black :)
  25. sprucewag macrumors newbie

    Jul 13, 2009
    Versalink 327w and TIME CAPSULE

    Thanks for the helpful thread!

    Before I go to download this corrective firmware, I wonder, does anyone know if somehow the wireless aspect of the versalink 327w can/should be deactivated so that the time capsule can be the wireless network base in the home? Or, like everyone else seemed to fear, I must go out and buy another modem to hook the Time Capsule into?


Share This Page