imac airport utility, sudden signal drops

Discussion in 'Mac Accessories' started by bstjose, Nov 19, 2008.

  1. bstjose macrumors newbie

    Joined:
    Nov 18, 2008
    #1
    hi I've had my iMac 20" since their last upgrade (mid summer). I switched to a linksys N wireless home router and it has been working great ever since. But three days ago a woke up turned on the mac and the signal bar drops to one ( I usually get 4 bars with linksys signal expander) and the internet is really slow and laggy I tried trouble shooting and everything i ran diagnostics and assistance and it told me that the network needs a password when it doesn't need one (the network is not secured, and no it wasn't hacked cus my other PCs at home are fine). It displays the network in the preferences but it won't connect. the utility icon displays yellow with connection timeout. I tried again two days later final it connects to the network and it's got 4 bars! but it drops back to 1 within 5 minutes and now i'm pretty much stuck at one bar. I've tried everything. can somebody please help me!

    p.s. the router is on the second floor of my house and i'm working on the first floor with a linksys signal expander. I'm the only one in the house with a mac and my other PC works fine two feet away with excellent signal.

    Is it the network or the mac
     
  2. xfirstonmylistx macrumors newbie

    Joined:
    Dec 1, 2008
    #2
    The same thing happens to me, so I believe it's a Mac issue. I have a 2 month old iMac 20" and pretty much since I took it out of the box I've had issues with the wifi signal. It has the capability to hold the 5 bar signal, yet every time I wake it up or some times sporadically throughout the day it will drop to two bars and only after going through the network diagnostics utility 5-10 times does it hold the signal again. My router is on the first floor, yet I don't think this is an issue because, like I said, it will hold the five bar signal, but only after repeating that annoying utility over and over again. I haven't had a chance to talk to a mac expert, but hopefully someone on the forum can offer a better suggestion than blaming it on the signal strength. Also, the diagnostics asks me for a password even though there isn't one so I just leave it blank when I press continue. We pretty much have the same exact problem so you aren't going crazy.
     

Share This Page