Imac & airport wireless issues

Discussion in 'iMac' started by buyusfear, Jan 11, 2008.

  1. buyusfear macrumors 6502

    Dec 30, 2007
    I recently purchased an 24' Imac and a 15' MBP. I'm glad I have the MBP as I wouldn't be able to ask this here, or anywhere else on the internet for that matter, since my Imac doesn't want to connect to the network. I've had it for 3 days now, and this is the second time it's happened. The last time it just started working. This time I have no luck. It just tells me its unable to connect to the network.

    I know it's not a password issue or network issue or distance issue as I'm connecting to the same network with my MBP right beside my imac.

    Help would be greatly appreciated

  2. buyusfear thread starter macrumors 6502

    Dec 30, 2007
    OK, now it's working, as I type this from the imac.

    I don't get it.

    :mad::mad::mad:errrrghh OSX, if you weren't such an improvement over my last OS i'd throw both you's off of the balcony.
  3. djejrejk macrumors 6502a


    Jan 3, 2007
    Call AppleCare or take it in and have Apple replace the Airport card. Couldn't hurt to ask.
  4. Theatrics macrumors member

    Apr 1, 2007
    San Diego

    If its a linksys router, than thats your problem. Linksys routers tend to not play well with Macs. The problem can be fixed by using a manual network location.

    Go to System Preferences > Network > Settings for AirPort

    Click the location drop down menu and create a new location named Manual.

    Press the Advanced... button. (in Leopard) to get to the advanced options...

    Navigate to the TCP/IP section and use the following settings:

    IPv4 Address:
    Subnet Mask

    and keep Configure IPv6 at Automatically.

    In the DNS section add the following DNS servers:

    It takes a few seconds for these settings to kick in, but it should allow your Mac to work just fine with a linksys router. If these settings dont work for you. Its possible that it is the airport card in the machine. In this case, press the top left apple in the menu bar, go to locations, and switch back to Automatic.
  5. TelescopeEyes macrumors newbie

    Jan 12, 2008
    I've also been having problems with my Airport base station and my Mac Mini. It disconnects from the network often.
  6. buyusfear thread starter macrumors 6502

    Dec 30, 2007
    My router is an Airport extreme 802.11n

    It did it again last night so I just connected an ethernet cable, got so fed up.

    (the cable was there from my old PC, but I kinda liked the fact that I had wireless)
    At least the MBP works on it...

Share This Page