Imac and External Harddrive Issue. I = Worried

Discussion in 'iMac' started by andrewbring, Jan 19, 2011.

  1. andrewbring macrumors newbie

    Joined:
    Jun 15, 2010
    #1
    You guys gave me confidence and advice in buying my imac, now I must turn to you again!

    I have the newest updated imac i7. Will post specs below.

    I also have an external Samsung 1 tb connected using a usb dual docking bay connected with a usb 2.0 cable.

    This is where I may have failed:
    I was burning a data cd-r with files that were ON the external harddrive.
    So I did not drag the files I wanted burnt onto my desktop.
    Instead I inserted the cd-r, then on the finder opened my harddrive and dragged the files onto the cd. Then clicked burn. M

    Midway at the finalizing stage, the harddrive unexpectedly Ejected itself.
    The dialogue box stating it ejected popped up.

    Then, I shut down my dock and tried to boot it up again.

    When I open Disk utilities, I notice that the hard drive is mounted, but the indented "volume" underneath, is grayed out and is unable to mount.
    I did a first aid-verify disk on both icons and both said disk "appears to be OK."

    I tried shutting down my Imac and removing all usb cables and even turning off the power surge that it's connected to. I let it sit for a little bit and restarted everything.

    Still the same.

    Side Notes:
    - I DID notice this happen to another one of my portable harddrives the other day. But it simply remounted after a while. Didn't think much of it. Plus, that may have been a loose power cable.
    - It's a dual bay dock, so I had another harddrive in it, that did not unmount. And can still mount correctly. I have taken that harddrive out of the picture while trying to fix the 1tb samsung. It is not plugged in any more.
    -I would preferably .. actually vital.. would like to keep the data on the disk. Simply reformatting it would kill me. And my career as a filmmaker!

    Thank you everybody in advance for your advice.

    Let's hope stuff works.

    Andrew


    IMAC:
    Model Name: iMac
    Model Identifier: iMac11,3
    Processor Name: Intel Core i7
    Processor Speed: 2.93 GHz
    Number Of Processors: 1
    Total Number Of Cores: 4
    L2 Cache (per core): 256 KB
    L3 Cache: 8 MB
    Memory: 8 GB
    Processor Interconnect Speed: 4.8 GT/s
    Boot ROM Version: IM112.0057.B00
    SMC Version (system): 1.59f2
     
  2. mjsmke macrumors 6502a

    Joined:
    Mar 2, 2010
    Location:
    UK
    #2
    Do you have a backup of the drive? If you do, reformatting would sort the issue out.
     
  3. andrewbring thread starter macrumors newbie

    Joined:
    Jun 15, 2010
    #3
    Baskets in on egg.... eggs in one basket.

    nope... no backup.

    I know I'm at fault here.

    I put all my eggs in one basket.

    Regret #1.
     
  4. davids8477 macrumors 6502

    Joined:
    Jan 4, 2008
    #4
    I had a simllar problem with an external RAID 5 enclosure - suddenly it was gone - and all my pics and music.

    When I tried to repair it - Disk Utility - I got the message that there was and issue with the B Tree (or something like that) and it needed to be reformatted!

    I purchased a copy of Disk Warrior - ran it an it fixed the problem in about 5 minutes - highly recommended.
     
  5. Stan Mikulenka macrumors 6502

    Joined:
    Nov 20, 2009
    Location:
    Calgary, Canada
    #5
    Hi andrew,
    as davids says, you have to use commercial Utility app for fixing something like that.I use these utilities - you (and everybody else) should have at least one of these...:
     

    Attached Files:

  6. andrewbring thread starter macrumors newbie

    Joined:
    Jun 15, 2010
    #6


    Thanks everybody.

    I'm planning to bring my harddrive into my work where some of my neighbors may have the program since they are help desk tech people.

    I assume they will have the program.
    If not I will take a shot.

    Wish me luck.

    I'll report back, hopefully with all my data back and reading posts on RAID and Drobo.

    Andrew
     

Share This Page