iMac and HDTV don't match

Discussion in 'iMac' started by eetu, Jun 4, 2008.

  1. eetu macrumors member

    Joined:
    Oct 23, 2007
    Location:
    Tampere, Finland
    #1
    I have a pretty common problem, but I haven't found a solution to it yet.

    I connected an iMac (mid 2007) to a HDTV with mini-dvi to dvi to hdmi. It seems to work. I use extended display mode and desktop shows on both display. The problem is that I don't get full screen on the HDTV, even though Mac says that the resolution is 1920x1080. I get black lines on every border.

    I tried with a new Macbook (same connections, same settings) and it worked full screen on both display right after plugging it.

    Any solutions?

    Thanks in advance.
     
  2. audiophile42 macrumors member

    Joined:
    Sep 12, 2006
    #2
    It might help to post your type and model number of HDTV. You also might want to look at www.avsforum.com , they'll probably be much more helpful with this type of problem. I'd bet the issue isn't with the iMac, but the HDTV. I know on mine, there are settings to select if the hdmi is being used to display a pc signal, and that fixed my issues. So look through your tv menus and manuals to see if there are any adjustments to be made for pc use.

    As far as the macbook working and not the iMac, I don't know. When you hook up a monitor to a computer, they send all kinds of information back and forth to each other that determines how the image is displayed. Maybe the macbook is taking care of that automatically, and you have to manually set the tv for use with the iMac.

    Sorry I couldn't be of more help, those are just some ideas.
     
  3. eetu thread starter macrumors member

    Joined:
    Oct 23, 2007
    Location:
    Tampere, Finland
    #3
    Thanks anyway. The tv is the new Sony KDL-W4000.

    It's hard to say in which end are the errors. They just don't want to communicate with each other nicely.
     
  4. speakerwizard macrumors 68000

    speakerwizard

    Joined:
    Aug 8, 2006
    Location:
    London
    #4
    are you mirroring? an imac display is 16:10 ratio and hdtv is 19:9 so might effect
     
  5. eetu thread starter macrumors member

    Joined:
    Oct 23, 2007
    Location:
    Tampere, Finland
    #5
    It was easy. Apparently I just needed to active the option "Overscan" from the display preferences options.
     

Share This Page