iMac and my failed recovery attempt.

Discussion in 'iMac' started by LurifaxDK, Oct 25, 2014.

  1. LurifaxDK macrumors newbie

    Joined:
    Oct 25, 2014
    #1
    Hi everyone.

    As a first time mac user this is my first post on this forum and unfortunately not one I am happy to make.

    Two weeks ago I bought an old iMac 24" (early 2008) and although a bit old it still worked beautifully. I froze every now and then and I was told that a reinstallation of OSX would be advised so I followed an appleguide on how to do that but unfortunately I've been sitting at "This item is temporarily unavailable" for the better part of a week.

    Not being put off by a challenge, I thought that it must be simple enough to make a boot USB and install the OSX that way. Boy was I wrong.. I dont have another mac so I'm using a windows PC to do this. I've followed the guides from around the net and tried powerISO to make a bootable USB to OS X, tried to make one with transmac and even gotten 2 other DMG files (mountain lion and another mavericks) I've even done a virtualbox installation on my windows PC and saved the Yosemite installation files to make a bootable USB and still, every single time I get to "This item is temporarily unavailable" I can boot from the USB but when I get to disctools and select recover, machine is verified at Apple, I type in apple ID and pass and next thing I know I'm sitting at the same frustrating error message...

    So; what are my options? I live in Denmark so going to an Apple Care center og Genious bar isn't an option as they dont exists. I am completely clueless as to how it is even possible to lock myself out of a computer as thoroughly as I have done.

    Really hope that someone can help me.
    Kind Regards jake.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I'm confused by what you are saying here. So you can boot to the USB key installer okay? From there normally you would start Disk Utility then erase the entire disk to Mac OS Extended (Journaled) format then quit Disk Uitl and install the OS.

    I'm not clear what you are doing with recover and an AppleID. Neither would be needed for an install from a USB key installer.
     
  3. LurifaxDK thread starter macrumors newbie

    Joined:
    Oct 25, 2014
    #3
    That's what's confusing me as well. I dont understand why it keeps reverting back to disctools even when I select the USB drive on bootup. I cant seem to get it to install from the USB even when I select it when it boots.
     
  4. eduardrw macrumors 6502

    Joined:
    May 20, 2013
    #4
    do you by chance have a recovery partition on the hard disk from your previous installation?
    Reboot and hold command +R key at the same time.
    If that works, connect your ethernet/WIFI and install.
    Will take a while to download the installer -> a few GB.
     
  5. LurifaxDK thread starter macrumors newbie

    Joined:
    Oct 25, 2014
    #5
    Yes, I did that, and thats when I get the "This item is temporarily unavailable" :-(
     
  6. metanoiapi macrumors member

    Joined:
    Oct 16, 2014
    #6
    insert your flash media.

    Run

    diskutil list

    determine the device node assigned to your flash media (e.g. /dev/disk2).

    Run

    diskutil unmountDisk /dev/diskN
    (replace N with the disk number from the last command; in the previous example, N would be 2)

    I had to unmount my flash drive in order to get it to work.
     
  7. LurifaxDK thread starter macrumors newbie

    Joined:
    Oct 25, 2014
    #7
    I'm sorry but I'm not familiar with mac so I dont know where to input those commands. Is it in terminal?
     
  8. eduardrw, Oct 26, 2014
    Last edited: Oct 26, 2014

    eduardrw macrumors 6502

    Joined:
    May 20, 2013
    #8
  9. LurifaxDK, Oct 26, 2014
    Last edited: Oct 26, 2014

    LurifaxDK thread starter macrumors newbie

    Joined:
    Oct 25, 2014
    #9
    No its not working, I got a virtuabox running of the system so I might be able to do it in there. But thanks alot I'll try it out. :)

    Edit: I get the following error. Diskmaker error
    Edit 2: Was not detecting the USB in the virtualbox. Fixed it and Diskmaker is currently making a bootUSB of Mavericks as far as I can tell. Will report back later.
    Edit 3: Installing OS X mavericks on my iMac as I type this. Bloody brilliant Eduardrw. Thanks a million! :)

    Full stop. Freezing continues during installation. Same problem as it had before so I guess I'll try to open it up and replace thermal paste and clean dust out etc.
     

Share This Page