iMac and spanish layout kb

Discussion in 'iMac' started by LAS.mac, Jun 4, 2009.

  1. LAS.mac macrumors 6502

    Joined:
    May 6, 2009
    Location:
    Mexico
    #1
    I have a 2.4 Ghz imac (summer 2008) with a spanish layout keyboard (aluminium model, with numeric keypad).

    As such, my keyboard has a comma instead of the dot in the numeric keypad. Now, here in Mexico we use the US notation, i.e. the dot is used to separate decimal numbers. So, when I use Excel or such, I have to either use the dot in the alphanumeric key section, or the combination of Ctrl + Option + , of the numeric keypad, to generate the dot. This works fine, although it is cumbersome, being much faster only using the numeric keypad. However, there are differences depending upon the program I'm using: for instance, the aforementioned key combination works in iWork, in Office, in the calculator included in the widgets. But it does not work in the Calculator which is included in Leopard, that recognizes the comma as a dot.
    So, it seems that something is messed up in the system preferences. Where, by the way, my keyboard layout is set as Spanish ISO.
    Suggestions?
     
  2. Berlepsch macrumors 6502

    Berlepsch

    Joined:
    Oct 22, 2007
    #2
    There is a small freeware tool called Ukulele which allows to change the mapping of your keyboard. So you could set up your keyboard to send a period instead of the comma on the number pad.
     

Share This Page