iMac and VLC

Discussion in 'iMac' started by vankata, Dec 28, 2010.

  1. vankata macrumors member

    Joined:
    May 22, 2010
    Location:
    Sofia, Bulgaria
    #1
    Hey. A have a iMac from mid 2010. I instaled VLC on it. When i play animes in mkv format, for example Fullmetal Alchemist: Brotherhood, it's take abaout a min to start playing it. My question is, is that normal? When i play other movies, in mkv format, they start immediately.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    If it's very high quality, then it's not that abnormal. You could try another player though
     
  3. vankata thread starter macrumors member

    Joined:
    May 22, 2010
    Location:
    Sofia, Bulgaria
    #3
    Thanks. But why on my old PC the same anime started immediately? Just wondering.
     
  4. mrt209 macrumors 6502

    Joined:
    Nov 21, 2010
    Location:
    USA/Germany
    #4
    Do you have the 21.5in or 27in iMac? I had no problems with VLC on my 27in mid 2010.
     
  5. vankata thread starter macrumors member

    Joined:
    May 22, 2010
    Location:
    Sofia, Bulgaria
    #5
    I have the 21'5 model. It's not a problem. I was just wondering way it's happening. Hellhammer explained why and the anime is realy high quality:

    Format : Matroska
    File size : 331 MiB
    Width : 1 280 pixels
    Height : 720 pixels
    Display aspect ratio : 16/9
    Frame rate : 23.976 fps
    Resolution : 24 bits
    Colorimetry : 4:2:0
    Scan type : Progressive
    Writing library : x264
     
  6. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
    #6
    If you were to look at your cpu usage during the time the matroska file was loading, you'd probably notice that one of the cores was maxed out for the whole while. If so, then vlc is having problems loading and reading (obviously) your matroska file, and is causing for a temporary cpu loop, or hang.

    I've had that problem for a couple of days with hd matroska files on anime, and it's something to do with vlc not being able to properly decode the subs of the file. This can either be fixed with getting a newer vlc or doing something very specific with its preferences. Anyhow it's a known problem and you can possibly google it and find the solution on what to change in its preferences.
     
  7. vankata thread starter macrumors member

    Joined:
    May 22, 2010
    Location:
    Sofia, Bulgaria
    #7
    I found solution of the problem. I need to type this in the terminal http://ericphan.info/blog/2010/10/29/fix-slow-loading-mkv-files-in-vlc-in-mac-osx.html
    When i type it in the terminal it show me warning that it is dangerous to do that, and if i want to continue i must enter a password. The problem is that in the beginning, when i turn on tne iMac for the first time, i didn't enter a password and when a pass is needed i just press OK end that was enough. But now when i press enter it says that this password is incorrect. What should i do?
     
  8. vankata thread starter macrumors member

    Joined:
    May 22, 2010
    Location:
    Sofia, Bulgaria
    #8
    With the new version of VLC 1.1.6 the problem is fix and now everything is working fine.:p:D
     
  9. MacHamster68 macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #9
    creating a password ;)
     
  10. MacHamster68 macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #10
    sorry forgot you need the install disc and then go to utilities and then change password ,you find them near the small apple on the top after inserting the disc and selecting language
     

Share This Page