iMac Bricked? Grey Screen With Additional Problem

Discussion in 'Mac Basics and Help' started by m-stones, Nov 20, 2014.

  1. m-stones macrumors newbie

    Joined:
    Nov 20, 2014
    #1
    I've asked for help on the official Apple forum but just got a generic response which didn't help my particular case.

    Anyway, in a nutshell my problem is that I'm having the problem with the grey screen which is pretty common, but due to the fact that I'd previously tried to install Win7 which had failed, I'm unable to boot into safe(?) mode because my mac doesn't automatically try to boot into OSX.

    Here's what happened, a few weeks ago I'd been trying to install Win7 onto Mavericks, for some reason either my Windows disc or my drive wasn't reading the disc properly so I went ahead and used the work-around to install Windows from a USB drive (the option isn't automatically available in Mavericks), this involved editing the text file for bootcamp to allow a USB install. Anyway, this still didn't work for whatever reason so I gave up and continued using my Mac as normal for a couple weeks.


    One day I'd come to home to find my Mac powered up but with a solid black screen, I hadn't set restarted the computer or anything so I was just expecting it to be asleep. (I had notifications to update to Yosemite and that my PC needed to restart for app updates to take effect but I had been postponing them). It was completely unresponsive so I went ahead and restarted it using the power button.
    When it now loads up, because of the failed Win install, the first screen I get is a black windows style screen with "BOOTMGR IS MISSING PRESS CTRL ALT DEL TO CONTINUE". Obviously there's nothing I can do with that, sooooo

    I can hold the option key to choose where to boot from, Mac OSX gives me the Apple logo and the loading wheel and I can hear my hard drive working but ultimately it just stops trying to load after a minute or so and I get a blank grey screen, Recovery does just about the same too.

    I'm pretty sure I could resolve this if I was able to hold down SHIFT on startup to launch into the safe mode, but because I have to first hold down OPTION just to get it to launch OSX, holding shift does nothing because I'm supposed to hold shift at the point where I actually have to hold Option (Hope that makes sense). The same if I hold CMD + R.


    Is there ANYTHING at all I can do here? If I have to re-install from disc as a last resort I will do (will that even work?), but is there any way to at least save everything from my hard drive or am I doomed?


    Thanks for reading anyway I hope it all makes sense and I hope there's somebody out there that can offer some guidance because I am at a dead end
     
  2. jimsowden macrumors 68000

    jimsowden

    Joined:
    Sep 6, 2003
    Location:
    NY
    #2
  3. gerryf macrumors newbie

    Joined:
    Jul 25, 2012
    #3
    the problem here is we don't really know what you have in the way of resources to fix the problem.

    Do you know anyone with a macbook?

    What I would try is to make a mavericks USB install flash drive using someone else's computer, then boot your mac with that, then use the DISKUTILITY utility on the flash drive and recreate the boot sector.

    You should be able to do this by selecting your internal disk, then click on the Partition tab. Then move the triangular slider that adjusts the partition up and then back to where it was, the "Apply" button becomes active (it starts greyed out). You can now click "Apply," and the partition will be left alone, but the partition bootloader will be recreated.
     
  4. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #4

    Thankyou this is helpful, but unfortunately I don't know anybody else with a mac. I have a windows laptop im on right now, can I not burn Mavericks install to a disk and boot it up that way? I'm guessing it's not gonna be that simple right?

    All that you wrote above has to be done on another mac doesn't it?
     
  5. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #5
    help please :(


    Is there anything I can do from a Windows computer?
    I've tried burning a fresh Lion.dmg to both a formatted USB stick and a DVD but I don't get the option to boot from neither of them.


    Should I just throw this out of a window because I really don't think there's anything I can do
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Before you go off the deep end (literally) - try this...
    Shut your iMac off. If you are not sure, press and hold the power button for five seconds.
    Disconnect power cord for 5 seconds. Plug cord back in.
    Press and release the power button, and immediately press and hold Option-Command-P and R. You should hear the boot chime sound.
    Continue to hold the same 4 keys until you hear the boot chime two more times. That should take less than 30 seconds. Release those keys during that third chime, and change to Command-R
    That should boot you up to the Recovery system. Choose Quit from the menu, which will show a small window that allows you to set the Startup Disk. Select your OS X drive by clicking on that icon, then click Restart.
    You SHOULD restart into OS X.

    If NONE of that really helps you - force-boot to your Internet Recovery system, by restarting while holding Option-Command-R
    You can release the keys when you see the spinning globe, which indicates that your Mac is connecting to Apple's servers. That boot can take several minutes, so be patient. You will get a menu allowing you to, among other choices, run Disk Utility - and repair your hard drive, or you can reinstall the version of OS X that your Mac shipped with.
     
  7. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #7
    Thankyou! :)

    Unfortunately, holding CMD/Opt P-R gives me the chime once, then straight onto the screen mentioned before saying "BOOTMGR is missing, press CTRL+ALT+DEL to Restart"

    Option CMD R takes me to the same screen as Option+R, with the options of Macintosh, Windows, and Recovery 10.9.2. No options for any internet recovery. No matter how long I leave it to load in Recovery I just get a solid blank screen after the HD powers up for a moment or two
     
  8. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #8
    Is there any shortcut keys to hold after the initial chime?
     
  9. aviddk macrumors regular

    Joined:
    Oct 18, 2007
    Location:
    SW Oregon
    #9
    Here is an article from MacLife with all boot options listed. I started through this list on a Macbook Pro and was able to find one command that helped me be able to reinstall.
     
  10. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #10
    OP:
    Doesn't it become frustrating in a situation like this, where you go around, and around, and around, not getting anywhere?

    I realize this advice won't help at the moment, but it WILL help in the future.

    In the future, get an external drive and create a BOOTABLE CLONED BACKUP of your internal Mac OS using either CarbonCopyCloner or SuperDuper.

    If you had had one when your current troubles began, you would have been back up and running in the matter of a few minutes, and found solutions more easily "in reach", instead of stumblin' around like you're doing now!
     
  11. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #11

    Incredibly frustrating yes! I've fought my way through many hardware and software problems over these past few years and always worked it out, and I've never been truly defeated up until now... I've been foolish enough to think I'd never hit a major problem that I couldn't undo so I think I've learned my lesson here with this.

    Thanks Aviddk this could potentially be a break!
     
  12. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #12
    i believe what you do in this situation is hold down the option key during boot

    it should come up with a prompt asking you to boot windows or os x

    if you corrupted your windows partition , it would do this. if the actual hard disk was messed up totally, you should of got a flashing folder with a question mark

    or you go command R recovery mode and select "start up disk" and change start up disk back to os x.

    if its an older mac and does not have a recovery partition then you insert your mac os x install disk and hold down the c key during boot. and then run select start up disk


    don't be jumping into this and erasing your entire hard disk. you probably don't need to

    once your back in os x. delete your bootcamp partition and start over
     
  13. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #13
    Booting into recovery mode gives me the loading wheel for a moment then back to a solid grey screen, I don't get any options for anything, I've left it for hours and nothing happens

    My Imac didn't come with an install disk :( I've tried burning a fresh install .DMG to a DVD and holding C on startup but It's having none of it... Any ideas?
     
  14. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #14
    using a properly made usb flash drive with os x
    if you read the directions
    requires you to hold down the OPTION key during boot and not the C key
    if your computer still has mac os on it, it will show up in the option menu
    i think

    if it boots then u should be able to go to " select start up disk " or disk utility

    booting from a usb flash drive is very slow. give it time


    If windows wiped out the entire hard disk. that might of happened. you were supposed to use the arrow keys to select the partition to write to


    the only other thing would be to
    perform a pram reset
    reset the smc controller

    before you erase the hard disk and reinstall the operating system from scratch
    have a genius look at it. they won't charge you for this.

    hopefully you have a time capsule for it
     
  15. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #15

    I have tried using a formatted USB through Transmac but still nothing, OPTION does give me the options of booting to OSX, Windows and Recovery, OSX and Recovery give me a solid grey screen, Windows is obviously corrupted.

    Holding C on startup is supposed to give the option to boot from CD, but like I said it doesn't work either.

    Done a PRAM reset also

    And no I don't have a time capsule saved, but at this point I don't even really care if I lose all my data I just want my Imac to work

    ----------

    And no I definitely only partitioned 100GB of my 1TB hdd for Windows
     
  16. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #16
    do a smc reset.

    pram does not clear smc.

    smc won't help but what the hell

    go to the computer store. pick up a copy of DISK WARRIOR for $100 from AISOFT and run that.

    hopefully that will fix it

    i think disk warrior comes on usb keys as well. i haven't bought a new copy since 4.0 if it comes on a CD, be patient. the CD has literally dozens of boot tracks used to boot vaarious macs, and it will take a while for the cd to load

    what else can you try???

    hmmm

    hold down the T key for target disk mode. connect another mac to the FIREWIRE or THUNDERBOLT port. depending on which port you have, and you can run disk utility or maybe even disk warrior on the OTHER mac to fix the drive.. or to erase everything and start over

    if target disk mode won't boot. then your iMac is totally shot

    maybe your hard disk physically crashed
     
  17. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #17
    I'm not even confident that my Imac will read from a USB or CD drive in its current state to be honest, so I'm reluctant to spend any money on software right now but I'll have too at a last resort. It's annoying with it being a 24" imac too it's hardly the easiest thing to carry around to a computer shop :/

    Is there any reason you know of why it won't boot from CD loaded with OSX Lion? Lion being the original OSX that it came shipped with. Holding down C sounds like its trying to work and then just ejects the CD and takes me to the black screen with "Bootmgr is missing"

    Holding down T for target mode does give me the Thunderbolt icon on the screen so I'm guessing that would work, but I don't have access to another mac


    I appreciate you trying to help here by the way thankyou
     
  18. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #18
    you don't need applecare to bring your mac to the apple store for help.

    applecare is only for REPAIRS or phone support.

    if it boots to target disk mode, then take it to the apple store and they should help you bringing it back into a usable state

    if target disk mode works, then disk warrior or disk utility should get the drive back into working order

    the only other thing i can think of besides reseting pram and resetting smc
    is draining caps

    shut down mac
    unplug from wall
    press power button for 5 seconds like your trying to turn it on
    plug in to wall

    then try smc reset or pram reset or booting from usb
     
  19. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #19
    The process for an smc reset is the same as draining caps so I've done that already. I think the only way out is taking it to the Apple store :(
     
  20. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #20
    once its in target disk mode you can even use the other mac to install os x
    on it over the cable!!

    i really wish you would give disk warrior a shot, you might not have to erase everything
     
  21. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #21
    what about internet recovery mode!!!!!????? will that let you run disk utilities or statup disk!!!!????


    Option Command R.
     
  22. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #22
    That's my problem here, I don't have access to another mac!

    And Disk Warrior is 85GBP which is pretty expensive without a guarantee of it working

    ----------


    Every other time I've tried that It's just taken me to the normal recovery screen and hangs on the grey screen BUT NOT THIS TIME IT MIGHT HAVE WORKED OMG
     
  23. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #23
    yeah , i forgot about that one. recent macs with no optical drives have
    recovery mode over the internet built into the firmware.. thats how you reinstall os x on an empty hard disk


    now my macbook pro is doing it and i to wait half an hour to install it before rebooting haha

    try select start up disk before you try disk utility or reinstalling the os

    this will reinstall the os to the os that you had when you first bought it. so you might have to go to the app store and reinstall yosemite, or mavericks, depending on what you had
     
  24. m-stones thread starter macrumors newbie

    Joined:
    Nov 20, 2014
    #24
    Okay I think my optimism might have peaked too soon, the bar fully loaded after 5 minutes or so but now I'm just back staring at a grey screen :( should it have popped up straight away do you know?
     
  25. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #25
    on my system i got the progress bar, it took 30 minutes because my wifi is slow
    and it gave me a start up screen to choose a language and i was able to click next
    and go into the installer

    where i could click on the apple logo to select start up disk or click on disk utilities
     

Share This Page