iMac can see Windows PC but can't connect

Discussion in 'macOS' started by likwidplastik, Mar 3, 2008.

  1. likwidplastik macrumors member

    Joined:
    Nov 1, 2006
    #1
    2.8ghz Al iMac running Leopard 10.5.2

    I can see my windows PC under "shared", but I cannot connect to it. After entering the username and password used on the PC, I get "connection failed". If I try to connect using the "command-K" method, I get an message saying "you do not have permission to access this server" after entering my username and password. I also cannot connect as a guest even though I have enabled the guest account on the PC.

    The PC and iMac are in the same workgroup.

    I have file sharing turned on the iMac and can access the iMac from my PC with no problems at all.

    In Tiger, I was able to access to the PC using "command-K".

    Any ideas? I'm stumped. I feel like I've tried everything.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    are you using XP or Vista? if using XP do you have "Allow network users to change my files" ticked in the Sharing tab of the shared folder/disk's properties sheet? also are you using your Mac's username and password? try your PC's
     
  3. IC3D macrumors regular

    IC3D

    Joined:
    Feb 15, 2008
    Location:
    Fairfield County, CT
    #3
    There is a program that networks osx and windows easy that Island put me on to, but I believe it should be relatively easy for leopard, but then again I haven't fully setup my network share on leopard yet. I'm assuming you googled or searched the forums for similar issues?
     
  4. likwidplastik thread starter macrumors member

    Joined:
    Nov 1, 2006
    #4
    richthomas: I'm using XP and I do have "Allow network users to change my files" ticked in the Sharing tab of the shared folder/disk's properties sheet.

    I tred using both my Mac's username and password and my PC's. I even created a new account on the PC and tried to connect to it with the mac using the new account...still didn't work.

    IC3D: I've searched forums, googled, you name it. I've tried several different suggested solutions from reading posts with somewhat similar issues, but nothing works. I haven't found anyone with the same exact problem that I'm having though.

    Just seems strange that I can access the iMac from the PC, but not the other way around. I figured I'd more problems accessing the iMac from the PC...go figure.

    I appreciate your comments.

    Any other ideas?
     
  5. 156457 macrumors 6502

    Joined:
    Jan 28, 2008
    Location:
    UK
  6. crumar2 macrumors newbie

    Joined:
    Mar 4, 2008
  7. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #7
    Mac side: First enable Remote Login (SSH) with System Preferences>Sharing>Remote Login

    Second note your IP address, in System Preferences>Network. (it should be of the form x.x.x.x where x is a 1-3 digit number, for home users it'll probably begin 192.1.1.x or something similar.

    PC Side: Download WinSCP, login using the IP address, as well as your Mac account username/password.

    EDIT: My method is a little harder to use, but it works, every time. Its using Unix filesharing stuff.

    EDIT2: Make sure you have a decent length login password, as you can do this over the internet too.
     
  8. mmcxiiad macrumors 6502

    Joined:
    Jul 19, 2002
    #8
    go in system preferences, click on sharing, then make sure file shareing is check. also click options and make sure that "share files and folders using SMB is also checked".

    Windows can't connect over AFP, which is all that is turned on by default. With SMB enabled windows should be able to access your mac's shared resources.

    if you do this you shouldn't need to do the ssh login.
     
  9. crumar2 macrumors newbie

    Joined:
    Mar 4, 2008
    #9
    But we want to connect to a shared folder on XP from OSX.
     
  10. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #10
    Does it really matter? Can't you just copy the files over the other way?
     
  11. crumar2 macrumors newbie

    Joined:
    Mar 4, 2008
    #11
    Sure. But it just annoys me a bit that it dont work anymore. I remember it worked just fine on Tiger.
     
  12. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #12
    Have you read the Mac Guide [guide]Networking Windows with Mac OS X[/guide]?
     
  13. crumar2 macrumors newbie

    Joined:
    Mar 4, 2008
    #13
    Yes.

    Like the original poster i can see my pc in finder. But when i enter username and password i get the message: "you dont have permission to access this server". I have made it so both machines are in the same workgroup. Also tried to write mshome\username since the login window in leopard doesnt have the choice of workgroup like tiger had.

    On the pc the firewall is disabled and rights to read and write are enabled.
    And i´ve tested both trough a router with cable and wi-fi, and with a cable directly between the machines.

    Thanks for any help.
     
  14. Wayne s macrumors regular

    Joined:
    Oct 12, 2007
    Location:
    UK
    #14
    Try this, system preferences---Network---Advanced click the WINS tab and enter your work group the click OK.

    I seem to recall some one telling me to do this when I had problems.
     
  15. Flowero4ka macrumors regular

    Joined:
    Jan 24, 2008
    #15
    What do you use to run Windows?? Bootcamp, parallels??
     
  16. Flowero4ka macrumors regular

    Joined:
    Jan 24, 2008
    #16
    What do you use to run Windows?? Bootcamp, parallels??
     
  17. Flowero4ka macrumors regular

    Joined:
    Jan 24, 2008
    #17
    What do you use to run Windows?? Bootcamp, parallels??
     
  18. likwidplastik thread starter macrumors member

    Joined:
    Nov 1, 2006
    #18
    Eraserhead: I've read the guide, still, no dice.

    Wayne s: I've tried that, still not working.

    Flowero4ka: Maybe I'm not being clear. I'm not running Windows on a Mac maching. My iMac is running Leopard, and my PC is running XP.

    Any other ideas? Still trying to get this to work.
     
  19. Wayne s macrumors regular

    Joined:
    Oct 12, 2007
    Location:
    UK
    #19
    I feel for you on this, I spent days trying to get my Mac - XP network working, and when it did work, I could never really put my finger on why it would not work in the first place. I just kept on persevering with it.

    Don't give up.
     
  20. cchervit macrumors newbie

    Joined:
    Apr 17, 2008
    #20
    @likwidplastik, did you ever find a solution to this? i still can't connect my leopard 10.5.2 to my winxp home laptop (same login permissions error).

    thanks.
     
  21. likwidplastik thread starter macrumors member

    Joined:
    Nov 1, 2006
    #21
    I still haven't figured out...I've oficially given up.
     
  22. cchervit macrumors newbie

    Joined:
    Apr 17, 2008
    #23
    thanks, likwid. i think it must only be a xp home thing b/c my xp pro desktop ended up connecting just fine. must be some kind of permission differences between the two, seeing as MSFT crippled some file-security/permissions stuff in the home version.

    btw, bonjour did not help. here's hoping that 10.5.3 will...
     
  23. cirejp macrumors newbie

    Joined:
    Apr 28, 2008
    #24
    Solution to Leopard access to SMB shares running XP

    Rejoice! I had this exact same problem and was about to give up hope, when the following tip worked and I now have access to my xp smb share from leopard 10.5.2

    turn off "Simple File Sharing" (Tools->Folder Options->View) on the PC


    I credit user Tolip with this genius workaround (however it works), posted to this forum: http://forums.macosxhints.com/showthread.php?t=80150

    I hope this eases much pain and suffering.
     
  24. btcomm macrumors regular

    Joined:
    Oct 18, 2006
    #25
    I have a suggestion for you.

    When it asks for the username and password, for the username type guest for the password type nothing.
     

Share This Page