Imac connection to wifi not automatic like mba

Discussion in 'iMac' started by RichyB, Feb 15, 2011.

  1. RichyB macrumors regular

    Joined:
    Dec 8, 2010
    #1
    Both my ipad and mba connect to the wifi immediately and automatically however my Imac requires me to manually connect each time, is there a simple solution to this problem?
     
  2. HvyMtlPlyr macrumors member

    Joined:
    Jun 25, 2010
    #2
    Don't know if this is necessarily the "correct" answer, but I had a similar problem with my wife's 21.5" iMac. Whenever it came out of sleep it wouldn't re-connect to my wireless network. Actually, it said it was connected but everything would time out. I'd have to stop, then re-start the wireless connection to get it to work. I ended up putting in a static IP and it works everytime now.
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    Open System Preferences->Network pane and at the top of the pane will be the 'Location' drop-down. Use the drop-down to create a custom named Location (calling home or anything you want). Then at the bottom of the Network pane click on the "Apply" button to save that new ocation. Then rejoin your wireless network. See if this helps.
     

Share This Page