iMac Core Duo - Sound Card Issues

Discussion in 'iMac' started by leVel, Jul 24, 2008.

  1. leVel macrumors member

    Joined:
    Jul 24, 2008
    #1
    Hello all,

    I have a first gen intel iMac Core Duo 2.0 from way back. I absolutely love the machine to death and it has proven to be problem free since its purchase the day of the intel announcement. A few months ago, I started getting into DJing and Mixing tracks with a usb midi controller through DJ software such as Traktor 3. I bought a Griffen iMic in order to cue up the next track while mixing through my headphones.

    Everything was working fine and dandy until one day, the imic usb soundcard doesnt work anymore. I unplug it, check it out, replug, nothing. So I take the sucker and throw it in my drawer. I replug my soundsytem into the built-in output, and as soon as I do, outcomes this faint and incredibly annoying screech. The screech doesn't really increase in volume as I increase or decrease the system volume. When I play music, I can hear the high pitched frequency slightly with music at a normal volume, and less at higher volumes. When I unplug my speakers and play some music through the internal speakers, the sound is gone!

    I've tried headphones, and different speakers, but again the moment the audio chord is plugged in, I get that annoying sound. I tried plugging the soundsystem into the usb imic, but I think the device is shot.

    Even more concerning is that over time I realized that my audio line out only sends out the signal for the left speaker. It plays through both speakers, but only audio from the left channel of the track.

    Thanks in advance for any help or useful suggestions,
    leVel
     
  2. leVel thread starter macrumors member

    Joined:
    Jul 24, 2008
    #2
    anyone? any idea's/suggestion/advice would be greatly appreciated.

    Thanks,
    leVel
     

Share This Page