iMac Display Not Sleeping

Discussion in 'iMac' started by innocentsheep, Sep 15, 2011.

  1. innocentsheep, Sep 15, 2011
    Last edited: Sep 15, 2011

    innocentsheep macrumors newbie

    Joined:
    Aug 27, 2007
    #1
    I've noticed that my iMac display is not sleeping after x amount of minutes (as set in the Energy Savings preference). What will happen is it will turn off, then half a second later, turn back on. When I do ctrl + shift + eject the display sleeps fine.

    Things I've tried: restarting, repairing disk permissions, resetting PRAM, and resetting the SMC. Did a search for other options, didn't find anything I haven't already done.

    I can't think of anything that changed recently, other than turning screen savers off (which, come to think of it, also never seemed to work properly), and we lost power at some point this week (though I'm fairly certain the issue existed before that).

    I'm running a 2011 iMac on Snow Leopard. Any help would be really appreciated.
     
  2. 88 King macrumors 6502

    88 King

    Joined:
    Jun 18, 2011
    Location:
    London, UK
    #2
    Can you unplug any USB or Firewire devices from the imac and try again.

    I had this problem few weeks ago, and it was caused by a USB receiver for an old Logitech mouse.

    Maybe also turn off the WIFI or internet connection, and make sure the Apple mouse and/or keyboard are the only devices connected via Bluetooth.
     
  3. psoin macrumors newbie

    Joined:
    Nov 8, 2005
  4. innocentsheep, Sep 16, 2011
    Last edited: Sep 16, 2011

    innocentsheep thread starter macrumors newbie

    Joined:
    Aug 27, 2007
    #4
    I don't see how this could be the problem though because wouldn't that still cause it to wake up with ctrl + shift + eject? It only won't sleep automatically. Likewise, all my devices/peripherals are the same when I didn't have this issue (right now: hard drives connected both through usb and a network, Wacom tablet, Apple wired keyboard, Magic Trackpad).

    I really don't want to use anything third party. Rather just figure out what's preventing energy saver from turning the display off.

    EDIT: As a sidenote, this is what I usually have running: Firefox, Twitter, iTunes, and VLC (and no, neither VLC or iTunes are playing things when this happens).
     

Share This Page