iMac doesn't sleep first time round?

Discussion in 'iMac' started by CBGFilms, Jul 7, 2010.

  1. CBGFilms macrumors regular

    Joined:
    Oct 16, 2008
    #1
    Before I go to sleep, I always put my Mac in sleep mode. But about 90% of the time it wakes up about 2 or 3 seconds later, and I have to put it back to sleep again.

    Why is this happening and how can I resolve the issue?

    Many thanks.
     
  2. wessew macrumors member

    Joined:
    Feb 4, 2010
    #2
    There are several possible reasons. First, do you have any USB hubs or USB peripherals (aside from the OEM mouse and keyboard) attached? If yes, disconnect them and see if the behavior is improved. Second, check for third party apps running in the background which may not permit the iMac to sleep. If fact, stop all running applications and see if the behavior is improved. Third, go into Energy Saver and uncheck put the hard disks to sleep...and also uncheck wake for network access. See if the behavior is changed. If none of the above is helpful then use disk utility to repair permissions. Check for behavior. Finally, startup your iMac using the install disk and run disk utility. Run repair disk on your main HD. These are all suggestions which may address the problem. None of them will harm your machine. Good luck.
     
  3. Mike Macintosh macrumors regular

    Mike Macintosh

    Joined:
    Sep 20, 2009
    Location:
    Washington State
    #3
    I agree with everything in this post, but I also want to add to uncheck wake for network access, that sometimes can wake the iMac as well.
     

Share This Page