imac fan problem! help!

Discussion in 'iMac' started by lamerlizer, Jan 1, 2008.

  1. lamerlizer macrumors regular

    lamerlizer

    Joined:
    Jan 8, 2007
    Location:
    singapore
    #1
    hi guys, i have an 20 inch alu iMac, and i got it when leopard released. but anyway it was quiet all the time, until two days ago, the fan started spinning at max speed, from the time i pressed the power button. it sounds like a mini vacuum cleaner! noisy! i checked istat for the fan speed but it did not indicate the fan speed. so i tried smcfancontrol and it too did not display anything. i did a hardware test and everything seemed to pass. should i bring to repair or is there a better solution? sigh, why must i repair every apple product i got. T.T
     
  2. GradientMac macrumors regular

    GradientMac

    Joined:
    Dec 5, 2007
    Location:
    Canada
    #2
    Make sure you don't have any intensive programs that are running in the background on your Mac. Check to see if you have anything that's opening on start up that's causing your Mac to be slow. Its happened to me on Windows but never my Mac though so I hope I'm of help!

    Thanks for reading!
    :apple:
     
  3. lamerlizer thread starter macrumors regular

    lamerlizer

    Joined:
    Jan 8, 2007
    Location:
    singapore
    #3
    :) thanks for your reply, but nope, nothing to do with intensive programs. god this sucks. T.T
     
  4. qpid macrumors regular

    Joined:
    Oct 18, 2004
    #4
    You probably have something stuck in your fan, probably hair or something equally small, either take it in to an apple service provider or try to blow it out with some compressed air
     
  5. lamerlizer thread starter macrumors regular

    lamerlizer

    Joined:
    Jan 8, 2007
    Location:
    singapore
    #6
    hm, i woke up in the morning today, checked istat pro and smcfancontrol, the fans are readable and its spinning normally again! weird
     

Share This Page