iMac Fans Going Insane!

Discussion in 'iMac' started by Zwhaler, Oct 27, 2007.

  1. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #1
    Hey all, I own a 2.33 Ghz iMac that I purchased a year ago, and things have been going great with it so far. I have not yet installed Leopard, but I plan to. On to the problem. This morning at about 7am, my house experiences a power outage... but luckily I have a backup battery to keep it on. The iMac was on sleep mode when it happened, and the battery started beeping, so I got up, turned off the iMac, and turned off the battery.
    Later that morning when I actually woke up, (power not out anymore) I turned on the battery, and then the iMac. But the second it turned on, the fans are blasting full speed. It is very noisy, and even restarting the computer produces the same results. Any idea whats wrong? Thanks.
     
  2. thecritix macrumors 6502

    Joined:
    Dec 11, 2006
    Location:
    West London, England
    #2
    I'm not greatly technical with these sorts of things..
    however, from what i've seen before, try restting the p-ram?

    (google it) this might tell the computer to buck its ideas up.

    or else threaten it with no leopard if it doesnt behave? :rolleyes:
     
  3. aethelbert macrumors 601

    Joined:
    Jun 1, 2007
    Location:
    Chicago, IL, USA
    #3
    As stated above, resetting the PRAM would be the first thing to try.

    Hold down these keys on startup:

    Command-Option-P-R
     
  4. Zwhaler thread starter macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #4
    Lol

    Thanks for the advice, after resetting the PRAM didnt work, I tried resetting the PMU, and that did the trick. Problem solved :)
     

Share This Page