iMac freezes when connecting to network

Discussion in 'Mac Basics and Help' started by pablo87va, Apr 2, 2018.

  1. pablo87va macrumors newbie

    Joined:
    Mar 28, 2012
    #1
    Hi all!

    I have an old iMac (model a1224 - 2008-2009) and I got a RAM upgrade for it to 4GB and a new 1TB hard drive.
    I've installed a fresh Mac OS X 10.6 (kernel is 10.0.0) and everything seems to be fine with the installation, the OS runs smoothly but I detected that when I tried to connect to any WiFi network, the OS just freezes, I can't do anything and I just see the spinning wheel, so I can only do a force shut down.

    I thought it might be something related to the Airport card, so I removed it completely and I tried the same but with an Ethernet cable, and it happened exactly the same.

    So discarted the Airport issue, it looks like it's a general issue related to any connection, when I start up the computer I can run any program and all just works! Issue appears anytime I connect it to any network, wireless or wired.

    I've searched quite a lot on the internet but I can't find any clue, so I'm running out of ideas.
    I would appreciate any help!

    Thanks a lot.
    Pablo
     
  2. Lunder89 macrumors 6502

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #2
    Is it 10.6.0? if so, try downloading the combo update 10.6.8 from another computer and install that.
     
  3. pablo87va thread starter macrumors newbie

    Joined:
    Mar 28, 2012
    #3
    Yes, it is 10.6.0.

    I have to say that I found out something to make it work, not sure if it will be just a workaround or a final solution, but I set an static IP (I thought it might be something related to DHCP) and in the same time I changed the priority of the network cards, and I set Bluetooth the last one, whereas Ethernet the first priority.

    Enabled back the interface and worked, I even restarted a couple of times and Internet was still there without no freezes.

    If it appears again I guess I'll install 10.6.8

    Thanks for your response!
     

Share This Page