imac freezes when playing games

Discussion in 'Mac and PC Games' started by shakir, Jun 12, 2008.

  1. shakir macrumors member

    Joined:
    Nov 14, 2007
    #1
    i have the alu iMac 2.0 c2d with 2gb ram. i know that apple computers aren't really strong in the gaming department so i chose to only install low requirement games. i only have warcraft 3 frozen thrones for DotA and sims 2. when dota first froze my imac, i noticed the problem lies with overheating so i installed smcfancontrol, problem solved. few month later, i installed sims 2 which doesn't nearly work my graphic card as hard as dota. just after few minutes of playing, my i mac froze. i had to reset by pressing the power button. this problem persists even after re installation. i decided to uninstall sims 2 and just play dota instead. unfortunately, dota froze my computer for no reason as well. temperature was well below overheating this time. i know it could not possibly be my ram and processor as both of them are more than capable of playing both games. i'm using leopard and have every latest update. so what seems to be the problem?
     
  2. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #2
    I'd fear you may actually have damaged hardware--such as RAM or GPU maybe--in need of warranty service. (Did you install your own RAM?)

    I bet there's something in your Console logs that could shed light on the crash but I don't know what to look for.

    As for software issues, one thing to try is creating a new user account, and installing/playing the game there. (It's much easier than re-installing the OS, but refreshes SOME of the files that can go bad.)

    (Disclaimer: I have no experience with those particular games.)
     
  3. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #3
    In order for others to help and to eliminate duplicate posting a few things:

    1. Did you search the forums for similar issues?
    2. No OS version number given, what OS X version are you running, that would shed a lot of light as those 2 games you mentioned have been brought up numerous times in the past and are quite a few currently running threads regarding them.

    On my iMac (I know it's different from yours) running 10.5.3 I can run W3 with frozen throne or without and runs just great.
     
  4. shakir thread starter macrumors member

    Joined:
    Nov 14, 2007
    #4
    not only have i searched the forum, but googled as well. nothing seems to help. hardware test shows no problems and yes, i installed my own ram. people have been saying it's because of memory leak or the graphic card. memory leak seems unlikely seems i never had page outs. and i notice this happens to other macs as well, even mac pro which got me to think whether it's leopard.

    btw, i tried frozen throne again and it worked fine again. this is really weird. i'm just worried if i try my hands on the sims again, the problem will come back
     

Share This Page