iMac FW 800 issue with Time Machine drive

Discussion in 'iMac' started by Achiever, Mar 7, 2016.

  1. Achiever macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #1
    I have my inlaws set up with an old iMac of mine (2007 24" model running Mountain Lion). For their Time Machine backups, I had a 500 gb OWC On-the-Go external drive plugged into the Mac's FW 800 port. Things were fine for a number of months until suddenly I was told they had a weird message on the screen that the drive had been ejected improperly. I assumed one of them had unplugged the drive or done something to prompt the message, but that doesn't seem to be the case. I tried shutting down the drive and remounting it, but it refused to mount onto the Mac. Even though the blue power light was on when plugged in, I thought perhaps the drive had simply died. I tried different FW wires to see if it was a wire issue but no dice. I tried to mount the drive on one of my machines and it wouldn't mount (or spin) either, so I chalked it up to a dead drive which unmounted improperly when the drive died. No big deal, though the backups would be lost.

    Yesterday I tried a different OWC OTG external drive & enclosure with a FW 800 input to set up their new TM backup. I had mounted the drive and wiped it clean on my computer, so I know the drive worked. When I plugged it into their machine, the drive mounted for all of 10 seconds before the machine kicked it off, presented the "improperly ejected drive" message in the corner of the screen and again refused to remount the drive no matter how many times I turned it and the machine off and on, unplugged/replugged, etc. That drive was spinning and when I brought the drive home it mounted on my machine and worked just fine, so the drive works. The oddest part of this for me was that this second drive DID mount onto the machine for about 10 seconds before getting punted.

    Is it possible for a FW drive to kill the external drives connected to it? Is there any way to test the health of the FW port? Is there anything else this could be? Is there any way I can force the intial drive to mount? I welcome answers to any of these questions. Thanks!
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Possibly a cable issue?
    Not making good contact at the iMac's firewire port?

    Could it be a "bus power" issue?
    iMac not supplying enough bus power to the drive?

    Do you by any chance have a USB2 external drive you could try instead?
     
  3. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #3
    Thanks for the response. I tried two cables ont he first drive and no dice. The second drive works on other computers (with both cables) so I don't think it is that.

    I will be trying a USB drive in the coming days to get the thing backed up, but would prefer (longer term) to have a TM drive plugged into the FW port.
     

Share This Page