iMac g3 no video after trying to upgrade

Discussion in 'PowerPC Macs' started by jdm111, Dec 23, 2008.

  1. jdm111 macrumors regular

    Joined:
    Dec 23, 2008
    #1
    Hi, So i had Ubuntu linux on my iMac g3 but i tryed to install Mac OSX Panther. It said i needed to update firmware. Fair enought. I thought i would install OS 9 with my recovery disc and do it that way. but when i rebooted there was sound and video but no image, I know the computer is booting properly because i can hear it, but no video, Please help.:apple::apple::apple:
     
  2. jdm111 thread starter macrumors regular

    Joined:
    Dec 23, 2008
    #2
  3. jdm111 thread starter macrumors regular

    Joined:
    Dec 23, 2008
    #3
    New problem now, I need to do the firmware update blind but how?
     
  4. jdm111 thread starter macrumors regular

    Joined:
    Dec 23, 2008
    #4
    New problem now, I tryed to firmware update blind. After 10 minutes of the imac making strange noises i had to pull the power. Now the thing won't boot! Can i restore the firmware?
     
  5. rfruth macrumors regular

    rfruth

    Joined:
    Feb 5, 2007
    Location:
    Texas
    #5
    I did the firmware update way back when & it went okay but that was on my fully functional G3, I don't know of a way to recover (some PC's blick their keyboard LEDs to let you know whats going on but you have to hold your mouth just so ...)
     
  6. jdm111 thread starter macrumors regular

    Joined:
    Dec 23, 2008
    #6
    Its really sad. I so want to get it working again for my dad:(
     

Share This Page