iMac G3 problems upgrading to Tiger

Discussion in 'PowerPC Macs' started by apachie2k, Dec 25, 2007.

  1. apachie2k macrumors 6502


    May 23, 2006
    was MIAMI
    i was cleaning out my basement and found my old graphite iMac G3 -- i figured i should update it from OS9 to something more modern, i picked Tiger because i was pretty sure it was supported (not like leopard)... anyways everything was going fine until it prompted me to update my firmware (i hate myself for not checking).. it then froze. I restarted the computer and never seems to startup again, it chimes and then [goes to sleep i think, the green light in the front is pulsing]. Anyways i have tried to reset PRAM, doesn't work... i have tried to boot from original boot cd, tiger cd... (note: i am using original keyboard and mouse - for the PRAM)

    Thanks for any help, i know it's some OLD technology...
  2. Ratpack1961 macrumors member

    Apr 7, 2006
    I had this exact problem happen to me when trying to install Panther. Essentially the firmware had to be updated before the install to prevent this from happening. The only way I was able to fix the problem was to take it to an Apple authorized repair place, where they then fixed the firmware problem (not sure how, I think they must have used an external monitor since the imac g3 monitor remains black when this happens) and then were able to successfully install the new OS.

Share This Page