iMac G3 Tray Loader won't change startup disk!

Discussion in 'PowerPC Macs' started by tevion5, Jan 13, 2015.

  1. tevion5, Jan 13, 2015
    Last edited: Jan 13, 2015

    tevion5 macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #1
    My girlfriend recently gave me the fantastic Christmas present of an iMac G3 (Tray Loading) Lime 333MHz. It's in super condition, and looks great in my collection.

    The only thing was that it came with the frustratingly useless Mac OS 8. I find it too modern for legacy purposes (I'd rather System 7), and too old to run most Mac OS 9 software. I wanted to put Mac OS 9 and Mac OS X on it, so I decided to install Mac OS X Public Beta alongside Mac OS 9.2.2, having never played with the beta before. I want to upgrade to Panther when I get more RAM, but figured Public Beta will be a fun toy until then. I was able to successfully manage this way, being able to switch the start up disk in Mac OS 9 or OS X.

    However, suddenly in Public Beta, the Startup Disk Menu in system preference crashes as soon as I try to open it. Holding down ALT on startup does nothing, leaving me stuck in OS X.

    I tried booting from my Panther disk and using the startup disk from that, but oddly, it crashes too! Directly after doing this, the iMac then began to boot with a white screen and some small black text appeared at the top left corner of the screen saying "bootr, unknown word". I reset the PRAM and I got back into booting Public Beta but I am still getting crashes when trying to switch startup disk.

    Anybody able to help me out here?
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    Can you use Terminal?

    You might try setting the boot disk via Terminal.
    Code:
    sudo bless -mount /Volumes/"name of your startup disk" -setBoot
    That command seems to be for OS X disks, but considering you have nothing to lose at this point maybe you want to try it? IDK.

    Anyway, name of your startup disk would be the actual name of the OS9 disk.

    I am assuming you have OS9/X partitioned as separate, but if you don't I don't think this will work.
     
  3. tevion5 thread starter macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #3
    Good idea, I hadn't considered that actually! Only unfortunately, I preemptively shot myself in the foot here by keeping both systems on the same disk. :/

    The drive is so small (Only 6GB) that I didn't want to partition it down any smaller.

    Anybody else have ideas? :)
     
  4. MonksMac macrumors 6502a

    MonksMac

    Joined:
    Dec 5, 2005
    Location:
    DFW
    #4
    Will the installer on the Public Beta cd let you select a start up disk from there? That or another older version of OS X from one of those installer disks?

    Or perhaps a OS 9 installation disk as well.

    My guess is that those older tray loaders don't love the later versions of OS X very much. :p
     
  5. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #5
    Have you tried resetting the PRAM? Often Macs will default to booting to OS 9 when their PRAM is reset.
     
  6. tevion5 thread starter macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #6
    Only tried to use the Panther disk startup disk menu and got the same result as Public Beta :/. I could try my Jaguar or 9 disk but I fear a similar result.

    ----------

    I already had to do this to fix the "bootr, unknown work" error I got. It booted straight back into public beta as soon as I did :/.
     
  7. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #7
    Looks like your OS9 install is broken somehow and causing the Startup Disk applet to throw a wobbly.

    Try blessing the OS9 folder by dragging the Finder out of the System Folder and putting it back. Most likely, you might need to reinstall.

    If you have both systems on one disk then the OF boot selecter screen will only show the last system booted so that you have to either use the Startup Disk function or manually select your system to boot from the OF prompt.
     

Share This Page