iMac G3 Tray Loading Boot Help

Discussion in 'PowerPC Macs' started by robbier, Sep 27, 2008.

  1. robbier macrumors member

    Joined:
    Apr 27, 2008
    #1
    Hello,
    I recently installed OS X 10.3 onto my G3 333MHz Tray Loading iMac. Whenever I boot it up, it goes right to the Open Firmware...it says "bootr unknown word." I have tried everything, I even tried typing in "setenv boot-command mac-boot" and it set the boot command to mac boot, and when i restart it ONCE it works but then it keeps booting to OF. I even tried to set the boot command in Terminal in OS X. Whatever I do, the boot command in OF always gets reset to "bootr". I have even replaced the PRAM battery (which if I am correct is on the logic board in the lower right, like a half AA battery) AND resetting PRAM. Nothing works, always boots into OF with incorrect boot command. The only thing I can think of is maybe I replaced the wrong battery?

    Thanks so much for any help,
    robbier
     
  2. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
  3. robbier thread starter macrumors member

    Joined:
    Apr 27, 2008
    #3
    Thanks, I guess Ill have to buy a copy of OS 9 to upgrade the firmware. BUT...now I have a different problem. I opened up the imac, disconnected and connected everything, pressed the little "reset" switch next to the processor card, and now when i turn it on i get the "bong" boot noise, but the CRD display never turns on and nothing happens. Any help?

    Thanks again,
    Robert
     
  4. bartelby macrumors Core

    Joined:
    Jun 16, 2004
    #4
    I think if you've tried to run OS X without updating the firmware it knackers the graphics drivers. I had a similar problem a few years back. Reinstalling OS 9 fixed it. IIRC
     

Share This Page