Imac G3

Discussion in 'PowerPC Macs' started by chris405, Feb 23, 2010.

  1. chris405 macrumors newbie

    Feb 23, 2010
    quite a big problem here guys ive installed a new HDD into my Imacg3 and wen i put in the installation cd all i get is the apple logo that changes to a question mark and i cant use my old hdd as its busted :S please help! also i cant accese the desktop and ive tried holding c to get the cd to load and nothing
  2. Bennieboy© macrumors 65816


    Jan 15, 2009
    have you tried booting holding down the option key ( thats the one between the cmd key and the ctrl key ) ;)
  3. chris405 thread starter macrumors newbie

    Feb 23, 2010
    i tried that nothing happend, pushed the ALT button and got a puple/grey screen with forward and refresh button i clicked forward and nothing has happend ?? its starting to pee moff as i love this machine
  4. MacHamster68 macrumors 68040


    Sep 17, 2009
    first not all imac g3 are the same when it comes to the os , what imac g3 is it
    tray or slot loader and what mhz as that is important and even more important
    what operating system cd/dvd are you using to install (retail , the orange ones or the grey ones ..depending on os)and have you updated the open firmware in case you want to install osx on the new drive , because you gave little info

Share This Page