imac g4/10.3.9/can't access google?

Discussion in 'Mac Basics and Help' started by mccldwll, Nov 19, 2006.

  1. mccldwll macrumors 65816

    Jan 26, 2006
    Several times during the past 24 hours, including now, I can't access google with safari. I'm on an ethernet/usb adapter (fried ethernet port). Yesterday had problems reaching some other sites, and some worked fine. Google seems to be main problem now. When couldn't reach yesterday, had no problem getting there/surfing, on a g3 running 9.2. Anyone have any idea what might be going on? If doesn't go away, what browser might be a better alternative?
  2. R.Youden macrumors 68020


    Apr 1, 2005
    Have you tried resetting Safari? I think that as an alternative Opera is pretty good.
  3. dpaanlka macrumors 601


    Nov 16, 2004
    I doubt it's the browser thats the problem. You may be having DNS issues.
  4. stevep macrumors 6502a


    Oct 13, 2004
    Might be worth checking that your DNS server settings are correct for the isp you use. Possibly your isp's servers are not working well at the moment, or there is too high a contention ratio (which is an isp problem as well, not that they're likely to admit to it). Apart from that I can think of no reason that you can't access Google and other sites are ok. It's certainly not a fault with Safari.

    edit dpaanlka beat me to it !!

Share This Page