Imac G4 800mhz - can anyone diagnose this fault?

Discussion in 'Mac Basics and Help' started by adge666, Feb 2, 2007.

  1. adge666 macrumors newbie

    Feb 2, 2007
    I acquired an Imac G4 flat panel 800mhz which will not boot-up. When the power button is pressed, the tone plays, the small led on the screen illuminates and after a few seconds there is a slight flicker on the screen then nothing - just a black screen.

    I can hear a fan running inside. The cd tray will not open, if I gently turn the drive gear, the tray will manually open but doesn't seem to be connected to any power - there was a Tiscali Broadband startup disc in there - I don't know if this is significant.

    I'm just trying to figure out which piece of hardware (I'm assuming so far that it's hardware) is at fault or how I can fault-find.

    Is the tone generated by hard drive boot-up or is it hardware driven? Also I've tried all the reset procedures I can find but still the same result.

    I've had the base off, checked all connections, everything looks clean, back-up battery seems ok at over 3 volts.

    Any advice or suggestions welcome.
  2. classof2011 macrumors regular

    Dec 2, 2006
    Flying with American Airlines
    Probably a hard drive problem. Get a newer one that is S.M.A.R.T. and that should do it. But before you order it, look up on how to take it apart, do so, and check for any problems. Maybe leave it open, get the new hard drive, swap, snap together, and it should work. This was based from one of my own problems, the exact same thing but with an iBook.

    Oops didn't see the last part. Skip all the checking unless you want to try it again, but anyways I would go with a new hard drive.

    FYI, my iBook G3 has no hard drive yet it chimes. So I would *think* that the chime means a working motherboard.
  3. Shadow macrumors 68000


    Feb 17, 2006
    Keele, United Kingdom
    Correct; a chime means the Mac has passed POST, which means everything is hunky-dorey.
  4. lordjonny macrumors regular


    Sep 18, 2006
    I had the same problem with my macbook though i can't remember if the chime came on. It was the logic board according to apple, i took it to the store and they said they'd replaced it when i picked it up. About a month later i got rss and took it back they then revealed that they hadn't bothered replacing the board and reseated the ram which got it to start up. So they had to do it then which has so far mended everything. So:
    1. Try reseating the ram
    2. To see if its the board change the hard drive with another and if it does the same thing thats a good indicator according the apple guys.
  5. SuperCompu2 macrumors 6502a


    Jul 23, 2006
    I dont think it's the hard drive that's the problem. In my experience with Macs, if the hard drive was at fault you would get the question mark folder icon, and not a flickering display. I'd guess the RAM or PMU, but that's pretty much the generic mac problem solution.

    Re-seat RAM, maybe swap out DIMMs and see what happens. I doubt it's the Hard Drive personally, but I could be wrong. iMac G4's are beautiful machines, I hope you get it fixed.

  6. classof2011 macrumors regular

    Dec 2, 2006
    Flying with American Airlines
    Yes, no. 2 was what I think would solve it, or at least identify the issue.

    :confused: I'm guessing that means 'your two cents" ?
  7. TheMasin9 macrumors 6502a


    Dec 22, 2004
    Huber Heights, OH
    tone or chime?

    Are you hearing a system "BEEP" or are you hearing the "Doooong" from the speakers. If its the former, its probably bad ram, the latter, you probably have a bad hard drive etc. If its the latter, try booting off of a install disk.
  8. classof2011 macrumors regular

    Dec 2, 2006
    Flying with American Airlines
    I have never done this to a Mac desktop before, but for a Mac laptop it works...hold down the power button until it makes a different sound other than the chime. I know it means someone else can post what it does :eek:
  9. adge666 thread starter macrumors newbie

    Feb 2, 2007
    Thanks for the help... I've reseated the memory but perhaps need to check this out. I'm definitely getting the (what was it someone said - Booong?) chime - so post 'seems' ok.

    The thing that might be a clue, is that there appears to be no power to the CD drive, so I can't boot it any other way. If I carefully open the flap and gently turn the white nylon gear wheel, the tray will rack out, but at no point does any power apply to the tray mech, just seems dead.

    I was wondering if maybe a partly working power supply may be the culprit. Are there any voltages I can check for or ways I can test this theory?

    I've had an iBook G4 for nearly 3 years, which has always been 100% reliable, so I've never had to go down this road before.

    Thanks once again for your help.

Share This Page