iMac G4 Blue Screen After Leopard Upgrade

Discussion in 'PowerPC Macs' started by Targetyou, May 5, 2016.

  1. Targetyou macrumors newbie

    Joined:
    May 5, 2016
    #1
    I broke out my old G4 800mhz iMac the other day and decided to upgrade it to Leopard from Tiger. Using Leopard Assist, I booted to the install DVD and ran through the process with no issues. Once the system booted up after the upgrade it boots to a blue screen and goes no further.

    I'm stuck now. Any advice would be much appreciated.

    Here are the things I've tried that have not worked:

    -Resetting the PRAM multiple times
    -Unplugging the power cable
    -Running Disk Repair/Permissions Repair from the Leopard install disc
    -Booting into safe mode (does not work, still stuck on blue screen)

    I would love to find a solution to this, but I may just have to go dig out my old Tiger discs and start from scratch. I just don't know why it would hang like this after the upgrade.
     
  2. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #2
    It may be the install, or it may be the HDD. I would wipe the drive, and use the OF commands to trick the installer into thinking its an 867
     
  3. Targetyou thread starter macrumors newbie

    Joined:
    May 5, 2016
    #3
    Thanks for the quick reply!!

    I was able to use Leopard Assist fine, but I must admit, I'm not sure how to go about using the OF commands like you mention.

    It would be much easier to start with Leopard though, than to have to start back on Tiger.
     
  4. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #4
    Did you perhaps have APE installed under Tiger?

    APE, or Application Enhancer, is a system preference that almost all of Unsanity's apps used. The version that was current around the release of Leopard is incompatible and results in a blue screen and no further loading.

    Removing APE will allow the Mac to continue booting. You'll probably have to do that with target disk mode and another Mac. Google how to remove it.

    There is a later version of APE that is compatible with Leopard, but since most of Unsanity's apps broke and the company was in difficulties not many of their apps got updated. Shapeshifter in particular, their bread and butter, was abandoned.
     
  5. Targetyou thread starter macrumors newbie

    Joined:
    May 5, 2016
    #5
    I'm pretty sure that I did not have APE installed, but just in case, I will look into this. Thanks!
     
  6. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #6
    The issue with this is that leopard assist requires an OS to be installed. Try doing this,

    1. Reboot your Mac and hold down the Cmd-Opt-O-F keys until you get a white screen with black text. This is the Open Firmware prompt.

    2. Insert the Mac OS X Leopard Install DVD, or have it inserted prior to booting into Open Firmware.

    3. Type the following lines exactly as shown below into the Open Firmware prompt. Be mindful of capitalization, spaces, zeros, etc. If the command is properly typed and understood, Open Firmware will display “ok” at the end of each line after you hit “return”.

    dev /cpus/PowerPC,G4@0
    d# 867000000 encode-int " clock-frequency" property
    boot cd:,\\:tbxi

    4. Continue the install normally.
     

Share This Page