iMac G4 Hard Drive Upgrade Problems

Discussion in 'PowerPC Macs' started by Macintoshgeek, Mar 11, 2011.

  1. Macintoshgeek macrumors member

    Joined:
    May 24, 2007
    #1
    I just tried replacing the hard drive in my aunt's old iMac G4. Before the Mac Os X installation disc couldn't find a hard drive to install on. So I just replaced the Hard Drive today with a 80 GB seagate hard drive.

    Now, the same thing happens and Mac OS X can't install. I went back and checked as much as I could. I didn't want to actually take out the hard drive again and see if it is connected until I got some answers on here.

    I hear the Hard drive running, at least I'm pretty sure I'm hearing it and not the disc drive. But it still won't show up.

    Is it simply just a hardware problem, or what? Or else is it because I think I am using just a mac os x upgrade disc because I believe the machine originally had Mac OS 9 on it. Do I have to get my hands on a copy of the iMac's mac os 9 restore discs?

    Any help would be great.
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    Did you go into Disk Utility and format it to HFS+? If not do so. Also, what version of OS X are you trying to install?
     
  3. Macintoshgeek thread starter macrumors member

    Joined:
    May 24, 2007
    #3
    Sorry for my lack of knowledge in this area. How could I run disk utility if the computer can't run an OS?

    Also, I am not entirely sure what Mac OS X I am putting on or what disk is even in. I am pretty sure it is 10.0 because it is just a blue x, but I'm not sure. She gave it to me as is and I have found no way to eject the disc because I don't have a keyboard with an eject button on it.

    I also am guessing that the Mac OS X cd is one of many, so even if I could install it I couldn't do it all. I was going to worry about that after the upgrade, but the hard drive won't even show up as a volume.
     
  4. NZed macrumors 65816

    NZed

    Joined:
    Jan 24, 2011
    Location:
    Canada, Eh?
    #4
    For ejecting a disk, try this:

    http://docs.info.apple.com/article.html?path=mac/10.4/en/mh1750.html

    If you want to go on the Disk Utility, boot up with the DVD and after the welcome screen, on the bar on the top of the screen, click on Utilities then Disk Utilities. Click on your hard drive. then press the Erase tab, choose the Format type as Mac OS Extended (Journaled)
     
  5. williame macrumors newbie

    Joined:
    Aug 8, 2011
    #5
    Related problem - solution not seen here already

    Hi folks - new to this forum.

    I have a g4 laptop - powerbook (titanium, predecessor to the MacBook Pro). I have some ibookg4 startup disks from another machine, but not the 'official' disks for the powerbook.

    Had to install a new hard drive (or someone did it for me, to be accurate).

    Try the install CD disk but it cannot see the hard drive to make the installation. I can find the hard drive by firing up the laptop in target mode. I've used the utilities on another computer (macbook pro) to make sure the disk is properly formatted - no problem, and it checks out as healthy.

    But I still cannot install the system (10.4).

    So - given that 10.6.8 on my pro won't run on the ppc chipset (that right?) I'd be happy to get 10.4 to run. (I don't have 10.5 disks - but they would work?)

    Problem is - how to get the install disks to install. Or is it simply that they are too machine specific? Do I have to burn new edited files onto CDs? ;-( or is the simple answer to buy some g4 install disks? But could I be sure they'd work?

    Thanks
     
  6. Nameci macrumors 68000

    Nameci

    Joined:
    Oct 29, 2010
    Location:
    The Philippines...

Share This Page