iMac G4 reassembly

Discussion in 'PowerPC Macs' started by zackkmac, Jan 20, 2013.

  1. zackkmac macrumors 6502a

    Joined:
    Jul 7, 2008
    Location:
    Tulsa
    #1
    Hi everyone. My iMac G4 is going through a rough time so I need some help. Earlier I installed an SSD to boost the performance. The drive caddy that holds the optical and hard drives went back into place with no problems. However, I cannot seem to close the casing properly. Every time I try it leaves a gap near the front and I can't get 2 of the 4 Torx screws to go back in place.

    Also, the screen bezel popped off during transit. When I received it (bought it off eBay) I noticed the bezel was missing tabs along the top and bottom because you could wiggle it and see the LCD, but it was still on the screen pretty securely and was not an issue to me at all. Now, after looking at the bezel, it only has 1 tab to hold it in place out of like 20. The rest seemed to have broke off and are stuck inside the metal frame that the bezel snaps into.

    Anyone have advice on what I should do? A new bezel is $45 shipped at the cheapest. :eek:
    Also need some tips on getting the casing to close. I don't see what I did wrong. :confused:
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    When closing the dome, make sure you properly align the two notches. Also, make sure the AC power wires are where they belong, they can sometimes prevent it from closing. They can be a pain to close, sometimes requiring a bit of force. You can verify that the drive caddy is in there properly by opening up the optical drive door and seeing if the optical drive tray is properly aligned. Sometimes it looks like it is, but it isn't really.
     
  3. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #3
    also when you put it back...have you cleaned and reinstalled thermal paste to both side of heatsinks?
     
  4. zackkmac thread starter macrumors 6502a

    Joined:
    Jul 7, 2008
    Location:
    Tulsa
    #4
    Thanks for the replies. I have made sure to clean and reapply the thermal paste.

    When I use the iMac now, the optical drive tray seems to be aligned perfectly so I think that's okay. But when I use the Pro speakers, they have static and if I reach back there and adjust their connection, the computer freezes. So I think some cables are being pinched. But to me everything looks the same as it did when I pulled it apart so I am just pretty confused.
     

Share This Page