iMac G4 Sleep Issues (NOT what you're thinking)

Discussion in 'PowerPC Macs' started by Buddygor, May 22, 2012.

  1. Buddygor macrumors regular

    Joined:
    May 22, 2012
    Location:
    Northfield, Vt 05663
    #1
    Hi MacRumors!

    Glad to have found a PPC-specific section of your forums, I'll jump right in!

    I have an iMac G4 (and it's a beauty :D), 700MHz, 1GB RAM, 160GB HD (all upgraded, but sadly CPU/GPU are soldered :eek:), and I've done a clean install of Leopard on it, and updated everything. Now, I have literally taken long hours to find an answer for this, and it's simple. Before the Leopard Graphics Update 1.0, the Stacks and Folders opened fine, but when the display tried to sleep, it just went to full brightness; a frozen image of the desktop. It also slept fine. When I updated it, the Stacks and Folders had weird graphical lines and artifacts around them, and will never go away. The display sleeps fine, but waking from sleep every once in a while will bring my display to hell. Not a white screen as commonly disputed, but thousands of graphical artifacts just cover the display, and only a restart will fix it.

    I've reinstalled, reset the PRAM, PMU, restarted, even done this weird trick on Apple Community Support were you replace the Leopard drivers with Tiger ones, but that made it worse. HMMMMM :mad:. What can I do? Has anyone made a script, found a solution? ANYTHING? I certainly can't find anything anywhere. I have attached a photo of my 'display hell.' (and messed up Stacks) Please help if you can! Thanks a ton.

    Noah

    P.S. I will regularly check and respond if you have questions/ answers!
    P.S.S. This is my main machine! I cant go back to Tiger, what with even worse compatibility on a already-outdated PPC machine.

    Again thanks! :cool: :apple:
     

    Attached Files:

  2. marcusj0015 macrumors 65816

    Joined:
    Aug 29, 2011
    Location:
    U.S.A.
    #2
    Looks like a Graphics driver issue, it's probably overheating, have you checked the GPU temps?

    A bad PSU can mess up graphics cards as well.
     
  3. minifridge1138 macrumors 6502a

    Joined:
    Jun 26, 2010
    #3
    There may not be a good fix for this.
    Leopard isn't officially supported on you iMac. It requires an 866mhz cpu.
    So i'm guessing you use leopard-assist or some other hack / work-around to get it installed.
    There are some tips (search the forum) for running Leopard on unsupported hardware. There are features you can disable (i think spotlight, icon animation, menu bar transparency, etc) that are supposed to help it run.

    Good luck!!!
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    That screen could be caused by a burnt GPU chip or unstable power supply. But let's hope that it's caused by that Leopard Graphics Update. I've installed Leopard on the 800Mhz 15" G4 iMac. Same model as yours just slightly faster. I just tested its sleep and everything is working correctly. My suggestion, reinstall Leopard but don't install the Leopard Graphics Update.

    Running Leopard on non-876Mhz+ Macs doesn't have incompatibility problems unless you install it on a PCI Graphics or Sawtooth PowerMac G4 with the ATI Rage 128 card. That's the only G4 era thing Leopard doesn't have drivers for. It runs just fine on anything else with enough ram. The OP's iMac has a GeForce2 MX, which Leopard has complete driver support for.
     
  5. Buddygor thread starter macrumors regular

    Joined:
    May 22, 2012
    Location:
    Northfield, Vt 05663
    #5
    Response

    Thanks for so many fast replies!

    The GPU is cool, and my dad's PowerBook G4 has the MX2 GPU (with a 1GHz chip), so it's not incompatibility. Again, without the Graphics Update, I cant even sleep the display properly :(. I'm damned if I do, damned if I don't. So... What's left? I can't leave it. There has to be SOMETHING going on... Oh, and I disabled Dashboard and other stuff to help keep stress to a minimum. It shouldn't be stress though, as normal things (Pages '09, even GarageBand '09) run very well, especially considering my configuration. I'm pretty sure the power supply was actually replaced, so I'm stumped.

    :confused:
     
  6. Enjon, Sep 24, 2012
    Last edited: Sep 24, 2012

    Enjon macrumors newbie

    Joined:
    Sep 23, 2012
    #6
    Response

    I had a different issue with similarities. I was at OS 10.3 at the time. I had superdrive read errors & lockups after the G4 went to sleep and/or when trying to wake from sleep.

    Initially, I thought it was the superdrive (pioneer 106A) having dust on the laser or cheap CD/DVD medium. Cleaned with spray air and Q-tip alcohol but in time the problem only became more significant and frequent. Later results added corrupted file indications.

    It was difficult because, to my knowledge (which is very little), no authoritive source had provided an official response to the issue. Other threads indicated it was a result of a defective logic board (/motherboard), another thread indicated more specifically the video section of the logic board having gone defective, and yet other threads pointed to connected USB devices as a possible contribution to the problem.

    From your screen capture, it looks more to me like a loose fitting memory chip, or card, where an address line is not making a clean connection. This reminds me of discussions I had with other servicing outfits when I talked with their technicians. The G4 is very particular in the system RAM it uses (characteristics). One outfit, that I highly respect, refuses to warranty systems where the system RAM is not Apple, or RAM not originally installed by them; where they control the quality of the RAM being installed. At the time, my impression was they were talking specifically about the G4 systems. If it isn't Apple or theirs, the first thing they do in troubleshooting is to replace the installed RAM with RAM they trust, then start troubleshooting if the issue remains. In reading other threads, I have discovered that there is some borderline RAM out their that seems to operate fine in the first few months then after sufficient burn-in, and timely usage (till after warranty) the RAM timing characteristic drift slightly out of tolerance for the G4 needs, resulting in intermittent errors and corrupted files.

    In your posting, you hadn't mentioned whether you've used the Apple Hardware Test (AHT) utility possibly found on your original OS CD/DVD. See below USB test, then try the AHT for low cost initial troubleshooting.

    For me, I tried the AHT-No issues found, but it is a great place to start (after USB testing). The AHT has helped many others. I had to find another utility. From the service people, they pointed me in the direction of the free utility call "AppleJack" from the SourceForge community.
    It provided interrogative memory testing. It found some issues for me. As a result, I upgraded
    from: OS10.3 1G RAM, 80G HD, Pioneer 106A superdrive,
    to: OS10.4.11 2G RAM, 400G HD, Pioneer 118L CD/DVD-RW drive.
    I figured, that since you have to essentially tear apart the whole dome housing to get to the superdrive, then I may as well do a larger upgrade (and replace the PRAM battery at the same time). By the way, how old is your PRAM battery? From your posting, I know you reset the PRAM, but remember its battery backed-up. Do you have a good battery?

    After my upgrade, no more memory issues, no more HD corruption, and the new superdrive works great for burning and playback. I must have had more then one issue, the sleep/wake lockup issue remained, but I have developed a workaround. Before I get to that, I want to mention some of my internet research regarding the lockup issue.

    The connected USB devices may be a factor. The threads I saw indicate the USB plugged in devices overloading the USB hardware internal to the G4, by drawing too much power, and the G4 not monitoring it or seemingly not limiting, thereby allowing the devices to draw too much power. In my novice opinion, if you have a limited power supply, and other non-essential devices have uncontrolled power availability, then your essential systems sooner or later will suffer. Possible contributor is power bleed from aging electrolytic capacitors drying out.

    Recommend unplugging all rear connected devices except for the keyboard and mouse. If lockup still occurs, then try only the keyboard, or only the mouse. The technicians I talked with indicated that sometimes a mouse or keyboard can go out of spec and overdraw current (they can have aged electrolytic capacitors to and/or poor design). If need be, try someone else's newer keyboard and mouse. Try to narrow down if any of the devices are the problem.

    Just yesterday, I used a recently purchased new USB 2.0 external hard drive enclosure to use with an older magnetic disk 120GB SATA drive from a Macbook Pro. I wanted to rename the drive volume using the G4. When I plugged the USB drive into the G4, the screen went blank. When I unplugged the drive, I receive a kernal panic. This solidified (to me) there are issues with power draws coming from USB connected devices on the aged G4, but to what extent in your case.

    My personal suspicion is aged electrolytic capacitors on the logic/mother board allowing DC current to flow to various components, or to electrical ground, thereby putting additional power draw/burden on the lower voltage power supplies. Quit some time ago I had lockup issues when using my APC brand Uninterruptible Power Supply (UPS).

    When I was on the 10.3, after utility power loss for extend period of time whereby the computer had already gone into screen saver-then blank screen, it would not wake up on the return of utility power to the UPS, nor on mouse movement, nor keyboard tapping (but the fan was still running). On 10.4, I noticed similar results regardless of utility power being on or off. Lockup seemed to have nothing to do with the communication to/from the UPS. Was the USB port overloaded? My work around has been to have the computer active 24/7 (never deep sleep or hibernate). I can allow a screen saver to run. I have the following setting in the System Preferences/Energy Saver/Sleep Setting:
    1. Put the computer to sleep-->NEVER
    2. Put the display to sleep-->NEVER
    3. UNCHECKED-Put hard disk to sleep when possible.
    And under the System Preferences/Energy Saver/Sleep Settings/Options:
    Under heading Wake Options:
    1. UNCHECKED-Wake when modem detects ring.
    2. UNCHECKED-Wake for Ethernet administrator access.
    In same dialog window, under heading Other Options.
    3. UNCHECKED-Allow power button to sleep the computer.
    4. CHECK-Automatically reduce brightness of the display before sleep.
    5. UNCHECKED-Restart automatically after a power failure.
    The UPS still protects but with no communication to/from the G4; a compromise.
    I also setup the Dashboard & Expose in the System preferences to go into screen saver if the mouse is placed in the bottom right corner.

    Now, after my work session, I move the mouse to the bottom right and the G4 goes automatically into screen saver. After a few minutes, the screen goes from screen saver to blank, which is contrary to system preferences. I consider this as the power saving benefit (in a bad situation). Anytime after the G4 enters screen saver, or blank screen thereafter, I can wake the G4 using the mouse or keyboard. My limitation is no communication with the UPS, no heavy draw devices on USB (thumb drives are permitted, but no USB powered mechanical drives), and the G4 is on 24/7.

    I like the G4 appearance, location of the superdrive drawer being just above the keyboard & scrap paper level when inserting/ejecting discs, and superdrive permitting 3" CD/DVDs. Whenever my G4 goes south, I will retain the housing and maybe try putting together my first "Hackintosh" to bring it all up to new standards (CPU, logic board, and maybe touch display).
     
  7. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #7
    I would guess at a hardware GPU fault, and if not, then a hardware logic board failure.
     
  8. dbrewer80221 macrumors regular

    Joined:
    Jun 16, 2009
    #8
    I know I'm really late to the party here, but I think I know what part of your issue is:

    When running newer versions of Mac OS X (Tiger and Leopard), the iMac G4's GeForce4 MX GPU is not capable of Core Image rendering. This causes some minor graphical issues. One such issue would be the lack of the Dashboard ripple effect when a widget is introduced. Another would be an opaque menu bar in Mac OS X Leopard.

    I believe your issue stems from the fact that your graphics card is incapable of Core Image effects, and that includes opening/closing Stacks.
     
  9. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #9
    The stacks glitch is caused by lack of Core Image, but the second picture is caused by a failing GPU.
     

Share This Page