iMac G4 won't respond in Single User mode

Discussion in 'iMac' started by ChaoticDetour, Nov 27, 2014.

  1. ChaoticDetour, Nov 27, 2014
    Last edited: Nov 27, 2014

    ChaoticDetour macrumors newbie

    Joined:
    Oct 19, 2014
    #1
    I recently bought an iMac G4 to run some old games on.
    17" 1.25GHZ, 768 Ram running 10.3.9
    The previous owner erased all of his stuff but still has his user account intact, so it asks for an unknown password whenever I try to do anything. Empty trash, install games, he even has much of the preferences locked.

    So I tried starting up in apple S, Single User mode to delete the password
    /sbin/mount -uw
    rm /var/db/.applesetupdone
    reboot

    (I have tried slight variations of this I have seen on other sites)

    But the computer does not respond to any command. I have tried /sbin/fsck -fy as per apple support and nothing happens. Any command you enter it just sits there. No new lines appear. When you type "reboot" again, nothing happens it just sits there.
    I have gotten the message Carbon Lazy Values at times however.

    Any ideas?
    (I do not have an OS X CD that will work on this computer)
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    Few things:

    Removing the .AppleSetupDone (with the capitals) only forces the setup assistant on (re)boot, which creates a new admin-user.

    If you want to mount the boot-volume (read & write) you should type:
    mount -uw /

    Other than that:
    If you boot into Single User mode and just type reboot <ENTER> does that work..?
     
  3. ChaoticDetour thread starter macrumors newbie

    Joined:
    Oct 19, 2014
    #3
    That's how this all started. Trying to create a new user so I can delete the old 1 which I don't have the password for.

    I have tried just "reboot" right after getting into Single User and nothing happens on it either.
     
  4. ChaoticDetour thread starter macrumors newbie

    Joined:
    Oct 19, 2014
  5. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Can you try a different USB keyboard?

    You can't make changes to the hard drive in single user mode, unless it is mounted read & write. That's what the "mount" command does
    Try the command, typed correctly:
    Code:
     /sbin/mount -uw /
    (nothing will result without the final (space ) and / )
    And, I assume that you do remember to press Enter after you type each command (just checking for the simple stuff :D )

    then - for a slightly different method:
    Code:
    cd /var/db/
    rm .AppleSetupDone
    reboot
    again, press enter after typing each line

    Your Mac should then start up with the new user setup, so you can create a new user account. Once you get set up again, you can go into the Accounts pref pane, and delete the old user. You won't have any need for it.
     
  6. ChaoticDetour thread starter macrumors newbie

    Joined:
    Oct 19, 2014
    #6
    Thank you that worked. Yes I was not using that extra space and slash. No problems this time around. Thanks again.
     

Share This Page