Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iMac G4

bad03xtreme

macrumors 6502a
Original poster
Jul 16, 2009
594
116
Northern, VA
I have an old flat panel G4 iMac that I just have in my kitchen for email and music but my wireless no longer works. I bought and installed an airport card a few years back and it worked but now I can no longer access my wireless network. I have an airport base station for my wireless network and my iMac G5, Macbook Pro and iPhone connect fine but the iMac G4 cannot connect.

Do I need to upgraded to an AIrport Extreme card or is there an alternative method to get it to connect to my wireless network? :confused:
 

Jessica Lares

macrumors G3
Oct 31, 2009
9,360
833
Near Dallas, Texas, USA
Did you upgrade your internet recently? Maybe you just need to take it out and put it back in? Try that first. Maybe it went bad finally and you just need to buy a new one again?
 
Comment

bad03xtreme

macrumors 6502a
Original poster
Jul 16, 2009
594
116
Northern, VA
I haven't changed anything on my end, the airport card is working because it recognizes my network but it won't connect. It tells me "There was an error joining the Airport network "network name" ".
 
Comment

Aameiel

macrumors regular
Jan 22, 2011
161
4
Cape Coral, FL
If your imac is using an old airport card it cant use network security that high,but you can get a usb dongle to fix that problem.
 
Comment

Aameiel

macrumors regular
Jan 22, 2011
161
4
Cape Coral, FL
Depends on the model, I mite be wrong here but i think that only the 20 inch imac g4's can use a airport extreme. I know for sure that a 15 inch imac g4 can only use the old airport cards.
 
Comment

chibiterasu

macrumors 6502
Apr 5, 2012
337
24
London, The United Kingdom
Depends on the model, I mite be wrong here but i think that only the 20 inch imac g4's can use a airport extreme. I know for sure that a 15 inch imac g4 can only use the old airport cards.

Only the 15 inch with a 1.0 ghz, the 17 inch in the 1.0 and 1.25 ghz and lastly the 20 inch can use a airport extreme card, now because the op said that you already have a airport card (not airport extreme) you must have a older iMac g4 and as the two cards aren't interchangeable then you need a dongle. Airport should work up to wpa, airport extream for wpa2. Hope that helps :)
 
Comment

666sheep

macrumors 68040
Dec 7, 2009
3,628
237
Poland
If your imac is using an old airport card it cant use network security that high,but you can get a usb dongle to fix that problem.

It can. It needs WPA/WPA2 setting on the AP base station and minimum 10.3.9 on client computer.
 
Comment

666sheep

macrumors 68040
Dec 7, 2009
3,628
237
Poland
Intell, I wouldn't say that if I wouldn't work. With mixed WPA/WPA2 setting + b/g/n mode it works perfectly. I have AP Express set this way and my Clamshell connects to it without problems.
 
Comment

bad03xtreme

macrumors 6502a
Original poster
Jul 16, 2009
594
116
Northern, VA
Can you explain the process a little more? I tried changing the settings but couldn't get it to connect. I checked and it's only the 700MHz G4 so an Airport Express card won't work.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.