IMac G5 17" Checkerboard Graphics Problem

Discussion in 'iMac' started by flyguy321, Nov 9, 2011.

  1. flyguy321 macrumors newbie

    Joined:
    Nov 4, 2011
    #1
    Hi all, i have a 17" IMac G5, i switch it on and it starts booting etc, but the screen has a checkerboard effect all over it. When it gets the desktop, all it displays is the mouse with a checkerboard over it as well, now you can move the mouse but nothing else i.e. no icons etc. When i try and boot from the O/S disc, all i get are the fans running at full speed and again a checkerboard screen. I understand that the Capacitors go on these IMacs, so i recapped the entire board but this didn't help at all, just the same problem :(

    I know its not the screen itself, so the only thing left is the GPU. I know these can have problems as well. Should i try and reflow the GPU with a Heat Gun??
    Does this help at all??

    Any advice would be great :)

    Thanks.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    I'd say it's time for a new machine.

    Did you look at the capacitors to see if they were blown before replacing them? It's a very visible failure.
     
  3. flyguy321 thread starter macrumors newbie

    Joined:
    Nov 4, 2011
    #3
    I have since found that its the GPU Chip that is the problem, i am new to Macs and have bought a couple as faulty so i can repair and maybe sell them, this one had already had the Caps replaced but the problem still persisted. With nothing to loose i tried reflowing the GPU but it didn't work :(

    Thankfully i have found a replacement Logic Board on ebay and got it very cheap, just waiting for it to be delivered.

    I will update this post once i have received and installed it.......
     

Share This Page