imac G5 2.0 wont boot

Discussion in 'PowerPC Macs' started by Vanillagorila, Jan 9, 2010.

  1. Vanillagorila macrumors newbie

    Jan 9, 2010
    I woke up this morning and my imac wouldn't wake from sleep. then when it finally did I had a all black screen with a few red pixels at the top. the imac wouldn't do anything so I had to hold the power button down and restart. now when I try to turn it on, I hear the apple sound, I get the grey screen (10.4) with the white apple and a spinning circle, then it goes to a light blue screen and just sits there. I still have a cursor and it moves with my mouse.

    any thoughts???
    I'm thinking maybe my harddrive failed.
  2. DSPalpatine macrumors member

    Nov 9, 2009
    Could be the HD... have you tried to boot from the 10.4 install DVD and run disk utility? My Tiger-fu is failing me at the moment, as I've been on Leopard for quite some time, but if I remember correctly, Disc 2 of the Install discs should have the system utilities on it.

    Could be the HD, as I said above, but might also be any number of things, including a failing logic board.

    Once you can run some diagnostics, I'd also check the RAM. I had thought my G5 iMac was headed for the landfill with a bad logic board, but it turned out to be a bad stick of RAM. I had upgraded to 2 GB from the original 1 GB, and one of the sticks went bad, causing all kinds of neat and fascinating problems :(

    Also, if you boot into open firmware, what do you see?
  3. Vanillagorila thread starter macrumors newbie

    Jan 9, 2010
    I just installed new ram (2x1g sticks) last month. I thought that might be it. so I took each one out one at a time and tried to boot it. with no luck.
    I tried putting it one of the install disks but it won't read it.

    how do I boot into open firmware?
  4. rtrt macrumors 6502a

    Jan 19, 2008
    think open firmware is holdng down the alt key on boot. iirc should show what valid boot devices are available to the machine.

    if ive got it wrong then someone will be along shortly to put me right :D
  5. Hellhammer Moderator


    Staff Member

    Dec 10, 2008
  6. Vanillagorila thread starter macrumors newbie

    Jan 9, 2010
    I found the problem, I had two blown Rubycon 6.3v 1800uf capacitors. I replaced them and now I'm back up and running, limping along until I can I get a new Imac. :D

Share This Page