iMac G5 booting problem

Discussion in 'iMac' started by -ASH-, Jun 20, 2013.

  1. -ASH- macrumors newbie

    Joined:
    Jun 5, 2012
    #1
    Hi Guys..

    My imac has started to boot with problems..

    I have to press & hold the power button untill I hear the long bong (I think it's the pram reset unless someone will tell me diffrent). Then switch it off at the plug for a few minutes and then it will start..

    If I then switch it off.. It will come back on ok uptill about half an hour and after that, I have to do the whole process again..

    Any ideas??? Many thanks
     
  2. rabidz7 macrumors 65816

    rabidz7

    Joined:
    Jun 24, 2012
    Location:
    Ohio
    #2
    Your power supply is most likely dead. But I would check the logicboard because this sounds like the capacitor plague. Check the logicboard for exploded or leaking capacitors. If none are found replace the power supply.
     
  3. -ASH- thread starter macrumors newbie

    Joined:
    Jun 5, 2012
    #3
    Many thanks for that..

    I have checked the logic board but none are swolen so I think it could be the power supply..

    Am I right in thinking that these are prone for the gpu??

    Is this a problem that could be the gpu?..

    Thanks

    Ash
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
  5. -ASH- thread starter macrumors newbie

    Joined:
    Jun 5, 2012
    #5
    I like it.. (A nice & easy job for once).. :D

    Well, I could start their & see what happens..

    Thanks
     

Share This Page