iMac G5 - CD Won't Eject!

Discussion in 'Mac Basics and Help' started by winterdude010, Jun 14, 2007.

  1. winterdude010 macrumors regular


    Feb 24, 2006
    New York
    I was going to burn a CD but then I realized I did not have all of the songs highlighted in iTunes that I want to burn so I canceled the burn and the disc stayed in so I just highlighted the songs I wanted and clicked burn again but it told me to insert a blank disk. There is already a blank disk in there, and the computer doesn't even recognize that there is a CD in it. Not on the desktop, in disk utility, or in iTunes. Pressing the eject button doesn't work on the keyboard or by doing it in iTunes, I read about it online and it said to try the following:

    Type "drutil tray eject" or "drutil tray open" in terminal. Which also did not work.

    How do I get the thing out!?!
  2. j/k/Andy macrumors regular

    Jun 5, 2007
    Restarted your computer while holding down the mouse button.
  3. seewa macrumors newbie

    Feb 20, 2008
    Melbourne, Australia
    DVD or CD drive not ejecting?

    Had the same issue almost pulled the drive out to put in the PC to try and eject it but took the more inteligent aproach and checked the forums and thank you very much....

    Holding the mouse button on the reboot works a treat!
  4. sleez22 macrumors newbie

    Feb 8, 2009
    i tried that and it didn't work, this did:

    i had this problem tonight, tried everything on apple/support, no work!!!

    called support, the first thing he suggested worked, apparently a secret i haven't seen anywhere else!!! i searched for two freakin' hours, and 5 minutes on the phone worked!!!

    shut computer down, while holding the eject button on the wireless keyboard, turn computer on, eject as designed!!!

    i tried at least 5 other suggestions at least twice each to no avail before this.

    2008 intel based imac


    dragging icon to trash can. NO GO
    ejecting from itunes. NO GO
    eject via disc util. NO GO (gave message "unable to unmount", with no clue what to do!)
    reboot while holding Opt-Comm-O-F. NO GO
    eject in terminal. NO GO
  5. TofuGirl macrumors newbie

    Dec 19, 2009

    Restarting while holding the mouse button down worked for me. You and MacRumors are angels.
  6. MacUserSince93 macrumors newbie

    May 8, 2011
    Found easy fix for physical eject problem!!

    In the first place. I would like to say that CDs & DVDs with homemade paper labels are not the only ones that get stuck in iMac G5s. I have had many professionally made, factory produced picture disc CDs get stuck in my iMac.

    I finally noticed that one of the two dust protectors in the slot was folded inward, and the CDs were butting up against it when trying to eject... over and over.

    All I did was use the Vacuum Cleaner pipe (with no attachment) to suck the vinyl or rubber flap back to where it belongs. And (woohoo!) the CD popped out right away.

    Just place the end of the Vacuum Cleaner pipe square against the edge of the iMac and move up and down along the slot. This should suck the flap out to where it belongs. You can see it happen. This will also suck the dust out.

    You should ALWAYS suck the dust out of all slots and vent holes and jacks in all electronics anyway! Do this (with or without) the vacuum brush attachment (depending on the type of slot or hole). Never use a cloth or towel to dust electronics. This will drive the dust in. You must pull the dust out with a vacuum cleaner.

    Also... Speaking of home made paper labels. They are very dangerous. You can instead get some CDs or DVDs that come with white labels, and a printer that prints on discs. Just program the printer for Europe to enable this feature. You may have to look for a previous model of a printer to find one that you can do this with. But it sure beats all the time spent on the homemade paper labels that will peel off inside electronics.

Share This Page