iMac G5 Screen Flicker

skp574

macrumors 6502
Original poster
Jan 16, 2005
280
0
greenwich.london.uk
I was using my iMac today and noticed the screen seemed to flicker. I shut it down and left it for a couple of hours. When I turned it back on, the screen was really flickering. It looked as though it was divided into thirds horizontally. The top and botton thirds were flickering and garbled. The middle third was ok. I managed to log back in and restarted it again. It them seemed to clear. It's ok at the moment.

Has anyone had this problem before? I would think its either a dodgy panel or something up with the GPU?

I've had it for nearly two months and not had this problem before.

I guess if it continues then I should return it to the Apple store for them to have a look at it.
 

Voiteur

macrumors member
Jan 17, 2004
46
0
chicago, il
screen flicker

skp574 said:
I was using my iMac today and noticed the screen seemed to flicker. I shut it down and left it for a couple of hours. When I turned it back on, the screen was really flickering. It looked as though it was divided into thirds horizontally. The top and botton thirds were flickering and garbled. The middle third was ok. I managed to log back in and restarted it again. It them seemed to clear. It's ok at the moment.

Has anyone had this problem before? I would think its either a dodgy panel or something up with the GPU?

I've had it for nearly two months and not had this problem before.

I guess if it continues then I should return it to the Apple store for them to have a look at it.
I can offer you no help, but your post freaks me out. I've noticed my screen strobing/flickering several times as you would expect a CRT but not an LCD screen to do. Perhaps mine will eventually go your route :(
 

skp574

macrumors 6502
Original poster
Jan 16, 2005
280
0
greenwich.london.uk
I am going to an Apple Store today to pick something up. I am going to ask them what it may be.

I'll report back what information they tell me.
 

bellis1

macrumors 6502
Feb 9, 2003
263
0
Join the club.

Looks like your one of the lucky recipients of the bad VRAM, power supply, midplane problem. Mine just died two days ago after about 6 months but I had some small hints like yours after about 2 months. Apple will replace the part for you or you can do it yourself. I've got to put mine in this week and let you know how it goes. You can check your console for graphics chip kernel errors or run the hardware tests. Although neither turned up errors when I first had problems like yours.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.