iMac G5 won't start up, can't do a reinstall

Discussion in 'PowerPC Macs' started by Downhill theory, Apr 10, 2008.

  1. Downhill theory macrumors newbie

    Joined:
    Aug 15, 2005
    Location:
    San Diego
    #1
    Okay, so last week my power supply died, and I had it taken to the Apple Store, and they replaced it. It was given back to me, I turned it on, ready and eager to use it again, and when I opened up Mail, my computer froze up. I couldn't even do a force quit.

    So, I turned it off, and when I tried to start it again, it just got hung up on the white apple loading screen. It just sits there, spinning around, and after about a minute the fans kick on super loud. I've left it for almost 5 minutes, but it just sits there.

    I've tired using the reinstall discs, but when I get to the "Pick a Volume" it won't load anything, it just sits there "Gathering Information"

    I tried using the Leopard and the Panther discs, but with the same results. Disk Utility shows that I have the HD there.

    I'm really, really hoping that my HD didn't just corrupt out of nowhere.
    What can I do here? I'm not about to take it back to Apple because, whatever they did seemed to mess it up.

    Anyone got any suggestions what I can do?
     
  2. Darkroom Guest

    Darkroom

    Joined:
    Dec 15, 2006
    Location:
    Montréal, Canada
    #2
    this happened to a friend of mine last year and his MacBook... he couldn't choose a volume on install because his hard drive was dead, hence not being able to select a volume... i'm assuming your HD is dead...

    could be the Apple Store's fault though... their fix may have been more damaging than helpful... i can assure you that some so-called "technicians" at the Apple Store are retarded and should not be working there... another friend of mine, same situation, last year MacBook HD failed - apple replaced the HD and did the worst hack of an OS reinstall i've ever seen... fist they called the HD "APPLE STORE" or something unchangeable like that, and a bunch of apps were missing... and that's just the start, i'll let your imagination wonder...

    sorry about your computer...
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    I've seen poorly-seated RAM cause the same issues, so remove it and reinstall it.
     
  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Have You tried reparing your disk using disk utility on Your reinstall disks.
    You can also try to repair the permissions using the same disk utility.
    Have You got a bootable backup,if so try that.
    Hope it works.
    Succes Perry
     
  5. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
  6. Downhill theory thread starter macrumors newbie

    Joined:
    Aug 15, 2005
    Location:
    San Diego
    #6
    We tried resetting the PRAM first, but it didn't do anything.

    In Disk Utility, we tried repairing the disk, but it gets to about 1/4 of the way done and everything just freezes up.

    A friend of mine gave me Disk Warrior, so, we're hoping that might work.


    Our next try will be Target Disk Mode
     

Share This Page